Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So here is my story: I've been thinking "Why am I using MySQL 5.1, if there is already 5.6 out?", therefore I wanted to install 5.6 on my debian root server(it is a playground/testserver, not a production server or so). After first fully making mysqldumps of the whole current 5.1 MySQL-server, I've unsuccessfully tried to install 5.6. After quite some rage that MySQL was running but no of my sites could connect to it(I guess the deamon didn't function or again the magic witch did some stuff), I decided to remove it but since it wasn't a debian-package, but one I installed directly from the website(tar file), I deleted folders: - /etc/mysql - /usr/share/mysql

and more, in order to get rid of it.

The problem I have now is, that I can't install anymore mysql successfully:

Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.1 (--configure):
 subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
                                      dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.1; however:
  Package mysql-server-5.1 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      Errors were encountered while processing:
 mysql-server-5.1
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

This code above is printed when doing "apt-get install mysql-server mysql-client" and it also asks me for a root password, which I enter but it will then print a message that it can't set the root password and that unfortunately without any exception-trace/error.

So I think I need to get somehow those /usr/share/mysql files again but any Google search points me to themes which are not related to my problems. I am thinking that in this case I have done something extremly dumb and something which happens rarely, henc the lack of information on the internet about my problem.

Any ideas what I could do? And is my assumption right, that those /usr/share/mysql message files are part of the default debian system(would be weird though)?

I really appriciate every help.

Thanks :)

share|improve this question

closed as not a real question by Michael Hampton, mdpc, EEAA, Ward, dunxd Feb 22 '13 at 14:07

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
You're using MySQL 5.1 because it's stable and properly packaged for your OS. –  mgorven Feb 21 '13 at 21:17
    
I think you are getting it wrong, this isn't a production server, it is a play/testserver and the goal was it to install something like a newer version of a programme without using apt-get. I do realize that 5.1 is extra tested and stable for my version of debian. Don't get me wrong please. –  XemsDoom Feb 22 '13 at 21:35

1 Answer 1

up vote 1 down vote accepted

invoke-rc.d: initscript mysql, action "start" failed is telling you that executing service mysql start are failed, you can read the logs for problems.

Another approach could be purge the install with

apt-get remove --purge mysql-server-5.1 mysql-server

and try to reinstall

share|improve this answer
    
My server is now running again normally. I purged mysql-server, mysql-client and mysql-commons. Then I recognized that the message-files were contained in mysql-commons. So everything works now again on MySQL 5.1. –  XemsDoom Feb 21 '13 at 22:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.