Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I mount a USB Mass Storage Device in Debian?

The USB Stick is working on other computers.

I have used dmesg which returned useful information about the USB Stick. It is attached to /dev/sdc.

I tried to mount it using mount -t with different filesystem type parameters (ntfs, vfat, fat16, usbfs and usbdevfs).

Only one of these parameters seemed to actually result in something. It was usbfs. However, ls did not show the files which I stored on the USB Stick. Instead, it showed:

001  devices

I presume usbfs is not the right filesystem type. If it is not, then what is?

I am unable to use the Internet on the server for downloading specific packages for instance, since I am trying to install my network card driver on my server via USB.

share|improve this question

closed as off topic by Jeff Ferland, Sirex, Michael Hampton, mdpc, EEAA Feb 22 '13 at 3:46

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
"Without using the Internet"? What on earth does that mean? –  Michael Hampton Feb 21 '13 at 22:37
    
This would be on-topic for SuperUser or Unix & Linux, but it doesn't fit here and since I can't discern whether those fires are wrong or really what you're asking about in regards to, "Without using the Internet" (which you're on), I'm not keen to migrate. –  Jeff Ferland Feb 21 '13 at 22:41
    
I try my best to explain my question, but all i get is negative feedback. It means that I cannot install any packages or anything. –  user907560 Feb 21 '13 at 22:42
1  
@user907560 At the outset, your question is indistinguishable from end-user support and doesn't provide the information we need to know that the flash drive works elsewhere. This further information helps a lot. +1. –  Jeff Ferland Feb 21 '13 at 22:59
1  
@user907560 Server Fault is a site for professional system administrators, with a very specific scope described in our site FAQ. As it stands there is nothing about your question that indicates it is in the realm of "professional system administration" (as opposed to "end user asking a question about their personal/desktop machine") - This is why you are getting "negative feedback". Your question is not "bad", it just does not appear to be on-topic per the site's scope/FAQ. –  voretaq7 Feb 22 '13 at 0:00
show 3 more comments

4 Answers

up vote 4 down vote accepted

When mounting with -t usbfs, the source doesn't matter. usbfs is a DevFS virtual filesystem. Its contents are points to various devices.

Even USB drives are usually partitioned like hard drives, so you'll want to check ls /dev/sdc*. You'll probably see a /dev/sdc1. As many others have said, you'll find that mount usually detects the right filesystem. Mounting /dev/sdc directly is failing because you're trying to mount the partition table as a filesystem. Mounting with -t usbfs worked because virtual filesystem mounts ignore the source argument.

share|improve this answer
    
I would like to vote up, but I need to wait for some reputation. Thank you very much! Very thourough information. –  user907560 Feb 21 '13 at 23:06
    
My server is up again! :) –  user907560 Feb 22 '13 at 8:26
add comment

mount should detect the filesystem automatically in most cases. Your USB drive may be partitioned which is why sdc won't mount. Try the following:

mkdir /mnt/usb
mount /dev/sdc1 /mnt/usb

If this doesn't work, the output of blkid may help you identify the correct device name.

share|improve this answer
    
Thanks! I would like to vote up, but I need to wait for some reputation. –  user907560 Feb 21 '13 at 23:08
add comment

/dev/sdc is the full usb device, you cant mount it. You need to mount something like /dev/sdc1 (first partition) /sev/sdc2 (second partition), etc. The filesystem is autodetected, but you need to add the mount point, for example:

mount /dev/sdc1 /mnt

Will mount the first partition in /mnt directory.

share|improve this answer
    
Thanks! I would like to vote up, but I need to wait for some reputation. –  user907560 Feb 21 '13 at 23:08
add comment

to answer your question

Mounting a USB Mass Storage Device in Debian

identify your Stick with fdisk or similar and mount with

mount /dev/[device] /mnt

This works unless you have a an old debian version or strange filesystem on the stick.

However it seams you are asking the wrong question for your problem. Which is, "how do I install a driver for NetworkCard XY on debian (Version X) from CD or USB" ;-)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.