Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried to set up the kdump on my CentOS 5.8 system. I tried editing the /boot/grub/grub.conf and insert the line crashkernel=auto between the kernel and initrd entry. Then proceed on editing /etc/kdump.conf, set the path and core_collector and enable the kdump. After that, I reboot my system. But the OS does not boot this time. The kernel panic, it has this error: VFS: Cannot open root device "LABEL=/".

How am I to fix it? Is it because I add the crashkernel=auto line between the kernel and initrd entry on /boot/grub/grub.conf. I just followed the placement of crashkernel line on this tutorial.

EDIT

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/sda3
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.18-308.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-308.el5 ro root=LABEL=/
crashkernel=auto
        initZrd /initrd-2.6.18-308.el5.img
share|improve this question
    
I don't know why this happened. But try pressing the key 'e' while you are in GRUBs bootloader menu and then remove this line which you have added. Maybe then it will boot again –  mauro.stettler Feb 22 '13 at 10:17
1  
@mauro.stettler I just figure it out, I add letter Z on initZrd when I tried to exit the vi editor. –  Pelang Feb 22 '13 at 11:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.