Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have installed pecl_http on a PLESK server (which seems to be successful) but for some reason, the http extension will not load into PHP.


gives me bool(false).

pecl info pecl_http gives me a lot of info and if I run php -me http is also listed.

php -i | grep "http_request" gives me:

http_request => N/A => 0 => 0
http_request_datashare => GLOBAL => 1 => 0
http_request_pool => N/A  => 0 => 0

and if I run pecl run-tests -p pecl_http I get a lot of FAILs

and I am also getting

Fatal error: Call to undefined function http_get()

http.so is located inside /usr/lib/php/modules/ which is also defined as the extension dir in php.ini - all other extensions loads fine.

What have I missed?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Fixed by setting extension=http.so for specific domain

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.