Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am new to cPanel and have successfully installed WHM, and have created a new account. I can 'list accounts', and when I click on the cPanel login for my new account. A new tab is opened, but this page times out. The url for the account is...

Does this look OK? Additionally, we have cPanel installed in a VPN with internal and external IPs. I am wondering if the IP addressing could be the issue? Any comments or ideas appreciated.

share|improve this question

closed as off-topic by HopelessN00b Jan 13 at 20:29

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

This question appears to be off-topic because it is about working with a service provider's management interface, such as cPanel. – HopelessN00b Jan 13 at 20:29

1 Answer 1

up vote 1 down vote accepted

That URL xfercpanel will transfer you to the cPanel URL https://your-server:2083 and log you in as the username you selected.

Can you access https://your-server:2083 directly? If not, try without SSL: http://your-server:2082

Check to make sure that your firewall is not blocking port 2083.

I am not clear on what you mean by

we have CPanel installed in a VPN with internal and external IPs

Does the cPanel server itself have a public IP? (E.G. does ifconfig eth0 show a public IP address or a private one?) cPanel requires that a public IP be assigned directly to the server (E.G. no 1:1 NAT mappings)

Here's a brief list of ports which need to be open for cPanel / WHM to fully function:

  • 22 (SSH, optional)
  • 25 (SMTP, required for email)
  • 53 (DNS)
  • 80 (HTTP)
  • 110 (POP3)
  • 143 (IMAP)
  • 443 (HTTPS)
  • 465 (Optional alternate SMTP port)
  • 587 (Optional alternate SMTP port)
  • 993 (IMAP SSL)
  • 995 (POP3 SSL)
  • 2082 (Optional cPanel non-SSL)
  • 2083 (cPanel SSL)
  • 2086 (Optional WebHost Manager non-SSL)
  • 2087 (WebHost Manager)
  • 2095 (Optional Webmail non-SSL)
  • 2096 (Webmail SSL)
share|improve this answer
Hey Josh, my bad on the link above...I added the correct link in my original question. I tryed all the url suggestions you made, and none of those work. The server itself does NOT have a public IP when I do ifconfig, I see a private IP. So that is probably our issue. Thanks again for the help! – Lumbee Feb 22 '13 at 16:43
Ah, yeah, as far as I know cPanel requires a public IP assigned to the server. You might be able to make it work otherwise but I don't believe that's supported. Ultimately where you're trying to get to is port 2083 of the server, so maybe you just need to change your router/VPN/firewall/port forward/whatever setup. – Josh Feb 22 '13 at 16:45
For posterity where is a link on the matter:… – Lumbee Feb 22 '13 at 16:52
OK, I have a private IP now (no nat) and am seeing the same issue. Again when I click on the cpanel icon for the account, I get redirected to and it eventually times out. I also tryed your-server:2083 and your-server:2082 with no luck. I tried removing and recreating the account, and that did not make a difference. One of the weird things I did notice is that the default IP that is being assigned to the new account is the old private (192.x) ip. So its seems like that is still in CPanel somewhere, which might be part of the problem. – Lumbee Mar 7 '13 at 20:44
Solved. My admin had not opened up for 2083. Now that the port is open I can get to the CPanel console. Thanx Josh for all the help. – Lumbee Mar 12 '13 at 15:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.