Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to route a new ISP (Microwave link) from one of my out buildings to my computer room and hence my firewall. Old ISP came direct into firewall. In the outbuilding the Microwave modem connects with cat5 to HP Procurve 2524 switch. Because this ISP is coming through my internal network, I plan on using a new vlan called "airspeed" only for this ISP traffic. Up until now I've just been using the Default_vlan on both HP switches (4108 + 2524).

So far I've been unable to ping from my laptop to the ISP modem both of which are on the new vlan 2 ("Airspeed"). No traffic needs to cross from vlan 2 to vlan 1 so I've left the ports as untagged. I've used the subnet provide from my ISP as the new vlan 2 subnet. Can anybody see what I'm doing wrong here? I've added the configuration of both switch below.

Rough diagram:

Microwave modem (Gateway IP 77.75.00.49)
|
HP 2524 switch (port 24)
|
HP 2524 switch fibre link
|
HP 4108GL switch fibre link
|
HP 4108GL switch (port D1)
|
Laptop configured with IP 77.75.00.50 (for testing but will be connected to firewall)

And my 4108GL config:

; J4865A Configuration Editor; Created on release #G.07.21

hostname "HP ProCurve Switch 4108GL"   
cdp run   
module 1 type J4864A  
module 2 type J4862B   
module 3 type J4862B   
module 4 type J4862B     
ip default-gateway 128.1.146.50   
snmp-server community "public" Unrestricted   
snmp-server host 128.1.146.51 "public" Not-INFO   
snmp-server host 128.1.146.38 "public"    
vlan 1  
   name "DEFAULT_VLAN"   
   untagged A1-A3,B1-B24,C1-C24,D2-D24   
   ip address 128.1.146.203 255.255.0.0   
   no untagged D1   
   exit   
vlan 2   
   name "Airspeed"   
   untagged D1   
   ip address 77.75.00.51 255.255.255.248     
   exit   

Finally my 2524 config:

; J4813A Configuration Editor; Created on release #F.04.08

hostname "HP ProCurve Switch 2524"   
cdp run   
ip default-gateway 0.0.0.0    
snmp-server community "public" Unrestricted   
snmp-server host 128.1.146.51 "public" Not-INFO   
snmp-server host 128.1.146.51 "public"   
snmp-server host 128.1.146.38 "public"    
vlan 1  
   name "DEFAULT_VLAN"   
   untagged 1-23,25-26   
   no untagged 24   
   ip address 128.1.146.204 255.255.0.0   
   exit   
vlan 2   
   name "Airspeed"   
   untagged 24  
   ip address 77.75.00.51 255.255.255.248  
   exit   
no aaa port-access authenticator active  
share|improve this question

1 Answer 1

According to the configuration you posted, you only have one port (24) of the switch configured for vlan2. If your laptop and the modem are on different ports (which I presume they are) then both ports need to be untagged members of vlan 2 for this to work.

For example, if the other device is on port 25 you should have:

vlan 1
name "DEFAULT_VLAN"
untagged 1-23,26
no untagged 24-25
ip address 128.1.146.204 255.255.0.0
exit
vlan 2
name "Airspeed"
untagged 24-25
ip address 77.75.00.51 255.255.255.248
exit
no aaa port-access authenticator active

instead of what you posted.

share|improve this answer
1  
I've got it working now! I had to removed the IP addresses, but I also had to tag the fibre ports on both switches with vlan 2 "Airspeed" before it would work. All traffic between switches use the fibre ports and therefore needed to be tagged with vlan2. Another option is that I move the firewall out to the other building where the modem is located. This is how my config looks now; on the 2524 vlan 2 name “Airspeed” untagged 24 tagged 25-26 no ip address exit On the 4108GL vlan 2 name “Airspeed” untagged D1 no ip address tagged A1-A3 exit –  pan Jul 31 '09 at 13:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.