Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two VMs running on a Mac Server using VM Fusion 4. Both VMs are running windows 7, and I have SQL Server 2012 installed and data imported into VM1. Right now, I'm trying to figure out a way to access the data on VM1 from VM2.

I have tried to use telnet %ipaddress% %port% to test the connection. When I bring down the firewall on VM1, VM2 can access the database no problem. So I tried to create an Inbound Rule on VM1 to allow VM2's IP address. However, that just doesn't work out.

Here are my Inbound Rule Settings on VM1:

General: Allow the connection
Programs and Services : All Programs that meet the specified conditions
Computers: [Blank]
Users: [Blank]
Advanced: Domain, Private, Public (All Checked)
Scope:
   Local IP: 
      These IP Address: [VM1 IP]
   Remote IP:
      These IP Address: [VM2 IP]
Protocols and ports:
   Protocol Type: Any

Thanks in advance

share|improve this question
    
Is that a typo or did you enter VM2's IP as the local IP in a firewall rule on VM1? –  lsmooth Feb 22 '13 at 20:28
    
@lsmooth not a typo. Let me change that and see. –  Firyn Feb 22 '13 at 21:15
    
So I changed the local ip to VM1 IP, but it still doesn't work. Do I have to configure the outbound as well. Do I need to do anything for VM2 firewall setting? –  Firyn Feb 22 '13 at 21:19
    
Did you create the NICs of both VMs as NAT or bridged? –  lsmooth Feb 22 '13 at 22:12
    
I don't know, I need to get a hold of the network administrator before I can take a look. He insisted that all I need to do is to setup the firewall. –  Firyn Feb 23 '13 at 0:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.