Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to replicate a production environment so It's very important that I run PHP 5.3.15. The problem is that my dev server is running Centos 6 and the package manager will only install PHP 5.3.3. I've read that Centos 6 is forever tied to PHP 5.3.3 and upgrading is discouraged. Is this true? I've tried to install the PHP 5.3.15 rpm directly but it fails due to dependency issues:

error: Failed dependencies:
    libcrypto.so.6()(64bit) is needed by php-common-5.3.15-1.w5.x86_64
    libcurl.so.3()(64bit) is needed by php-common-5.3.15-1.w5.x86_64
    libssl.so.6()(64bit) is needed by php-common-5.3.15-1.w5.x86_64

Should I consider a different Linux distro for my dev environment? I'm newish to all of this so really appreciate someone who can clear this up for me.

share|improve this question
    
If you try to replicate a production environment, why don't you use the exact same OS? BTW, there are other repositories available for CentOS, but they all start at 5.3.18, not 5.3.13 (see pkgs.org). –  SvW Feb 22 '13 at 21:48
add comment

1 Answer

up vote 1 down vote accepted

You are trying to install a package built for CentOS 5 on CentOS 6. If you're trying to replicate the production environment, you should be using the same OS that production is using as well.

After a quick search using the package name above, it looks like the package was originally grabbed from the Webtatic Yum Repo. From that post, there are links at the bottom of the page for running 5.3 on RHEL/CentOS 5 and running 5.4 on RHEL/CentOS 6.

In short: you should be using the same distro and version/release that production is using if you're trying to replicate the environment.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.