Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i have installed CENT OS 6.3 on my server and given my router's wan IP to the server and done some port forwarding on the router but on the server i am not able to bring up eth0 and i am not able to access the server from remote location please tell me the needed things i must do to remotely access the server details wan.IP:115.115.183.xx router:CISCO RV042 server local IP:192.168.1.2 please help me out.......

share|improve this question

1 Answer 1

You say you have 'given my router's wan IP to the server'? what does that mean? The server does not need to be aware of your router's WAN IP if you do masquerading/NAT, because the server will never get to see it anyway.

So if your server's IP is 192.168.1.2, then on your router you will need to enter a portforwarding to that internal IP.

Then your server will get the packets with the original source address, but the destination address will be rewritten to its own internal one.

The servers reply packets will be sent with the destination address set to the source address of the previous packet, while it's source address will be set to the servers private IP. When this packet passes your router, the router rewrites the source address of the packet to it's own WAN IP.

So on the server you don't need to change anything, just leave it running on the private address and setup the portforwarding to the server's private address.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.