Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running Apache 2 on Ubuntu 11 in Amazon EC2. Tried to add a new SSL VirtualHost by doing the following:

Added "Listen 443" to ports.conf. Added new VirtualHost in my enabled site and "SSLEngine on".

The strange thing is this: I can curl https://localhost and get a response, but I can't curl my https url from a remote server.

Netstat shows that it's listening on 443:

# netstat -tulpn                         
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1923/apache2    
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      1923/apache2    
tcp6       0      0 :::22                   :::*                    LISTEN      482/sshd        

But, if I nmap the internal IP from another collocated EC2 box, it shows that only ports 22 and 80 are open:

$ nmap -P0 xx.xxx.xx.xx  

Starting Nmap 5.21 ( http://nmap.org ) at 2013-02-23 09:48 UTC
Nmap scan report for xxx
Host is up (0.00058s latency).
Not shown: 998 filtered ports
PORT   STATE SERVICE
22/tcp open  ssh
80/tcp open  http

Nmap done: 1 IP address (1 host up) scanned in 3.98 seconds

Additionally, I have verified that ufw is disabled and there are no entries in iptables.

Can anyone offer suggestions on how to troubleshoot this? Thanks in advance!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Does your AWS Security Group for your EC2 instance allow inbound 443? It needs to for HTTPS Traffic to work.

That sounds like it might be your problem to me!

share|improve this answer
1  
Yup, perfect. I actually just realized that myself and wanted to update it with the answer :) Thanks for your help! –  Chris Fong Feb 23 '13 at 10:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.