Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have PHP 5.3.3 on my CentOs 6.3 server, Since this version of PHP is vulnerable now trying to upgrade to PHP 5.4.11 but the default repository of CentOs does not have PHP > 5.3.3 so yum can not detect the newer version.

I then installed remi repository on my server

rpm -Uvh http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm

These command installed repository successfully

Now the command to upgrade PHP

yum --enablerepo=remi,remi-test update httpd mysql mysql-server php php-common 

But it fails with below error message

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

If i try yum info php the same error message

Basically after installing these repositories yum is not working, but yum was working earlier.

If I remove these repository and try yum it works without any error.

How can I have PHP upgraded to PHP 5.4.11 version?

EDIT As @Michael Suggests I ran

yum clean all
Loaded plugins: fastestmirror
Cleaning repos: base epel extras updates
Cleaning up Everything
Cleaning up list of fastest mirrors
`[root@www ~]# yum --obsoletes update
Loaded plugins: fastestmirror
Determining fastest mirrors
Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

Still the same error

EDIT 2

Content of epel.repo

[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 6 - $basearch - Debug
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch/debug
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 6 - $basearch - Source
#baseurl=http://download.fedoraproject.org/pub/epel/6/SRPMS
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

Internet connection is working well, I checked with

 wget http://google.com

EDIT 3

As @Michael Suggests I ran

URLGRABBER_DEBUG=1 yum check-update And It ended up with the following error

 Problem with the SSL CA cert (path? access rights?)
2013-02-24 20:31:45,730 exception: [Errno 14] PYCURL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)"
INFO:urlgrabber:exception: [Errno 14] PYCURL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)"
2013-02-24 20:31:46,051 retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-raising
INFO:urlgrabber:retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-raising
Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

So, the actual issue is with SSL certificate but why it is complaining about SSL certificate however it is valid one

share|improve this question
    
Does yum update not work? –  John Wheal Feb 23 '13 at 13:41
    
Have you tried downloading and installing/compiling from source? –  CIA Feb 23 '13 at 15:32
    
If I'm not mistaken, the remi yum package is called php54 or something simular. Please try run a #yum search php and look for the php package names. –  Danie Feb 25 '13 at 6:29
    
@Danie: The thing is after installing remi package, yum is not working –  sunlight Feb 25 '13 at 6:33
1  
Please run: URLGRABBER_DEBUG=1 yum check-update –  Michael Hampton Feb 25 '13 at 6:35

2 Answers 2

up vote 4 down vote accepted

After adding new repositories, clear your yum cache and update your system before attempting to install any more packages.

yum clean all
yum --obsoletes update

Based on your updated information, it appears your local CA certificates have been corrupted or removed. Try reinstalling them:

yum reinstall ca-certificates
share|improve this answer
    
still does not work same error. yum clean all Loaded plugins: fastestmirror Cleaning repos: base epel extras updates Cleaning up Everything Cleaning up list of fastest mirrors [root@www ~]# yum --obsoletes update Loaded plugins: fastestmirror Determining fastest mirrors Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again –  sunlight Feb 25 '13 at 5:57
    
Check the contents of /etc/yum.repos.d/epel.repo and make sure you actually have Internet connectivity. –  Michael Hampton Feb 25 '13 at 6:12
    
Michael, I posted content of epel.repo and checked the internet connection, internet connections is working. –  sunlight Feb 25 '13 at 6:27
    
I have godaddy SSL certificate. After running this command do I have to reinstall the godaddy certificate or does this automatically re install my godaddy certificate. Please help –  sunlight Feb 25 '13 at 7:34
    
Yes, yum reinstall ca-certificates did it –  sunlight Feb 25 '13 at 8:01

vi epel.repo

changed https in

mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch to mirrorlist=http://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch

WORKED!

share|improve this answer
    
I keep seeing this suggestion everywhere but disabling https does not seem to be the correct approach. –  Daniel Da Cunha Nov 17 at 7:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.