Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

First off, I know that this question exhibits bad practice, but the problem is being pursued from more an academic POV than practical application.

I'm using a number of Virtual machines (Using the most recent release of VMware). These machines include Windows XP Professional and Linux (Debian) servers. Again, I know that these operating systems (particularly XP) are not suitable for this purpose in a real-world setting. I wish to assign these machines static IP addresses instead of using the DHCP server dynamic addressing. And yes, again this is not an amazingly good idea due to the incurred micro-management.

Anyway; my question is this: I am aware that in this scenario the usual connection between host machine and VM (like this) is unsuitable for connection to the router, but rather a bridged connection is necessary. Having obtained the relevant information for the router and subnet mask through ipconfig on the host machine I now have the following setup on the XP VM:

ipv4 settings

Pinging www.google.com from host machine is successful, but unsuccessful from VM. Before assigning a static IP to the Virtual Machine the connection was sound. Mainly I am finding it difficult to... well.. even see how I can connect to the router. Perhaps it is due to the antiquity of XP, but connection to a wireless router is not in the least bit intuitive. I am fairly sure that just having a LAN network is insufficient on a VM with a bridged network to independently connect with the router, but the OS is stumping me at the moment. Any help would be appreciated. XP network connection

share|improve this question
    
why is your gateway ip blacked out? are you able to ping an external IP from your VM? gateway IP is essential for pinging external addresses, and must be in the same range as the VM IP –  Bahrain Admin Feb 23 '13 at 12:38
    
That was just me editing the screen picture. The gateway is the external ip address, isn't it? –  Duncan Feb 23 '13 at 13:45
    
I seem to be wrong; the default gateway is the internal ip address: the one I'm using is 192.168.1.254 –  Duncan Feb 23 '13 at 13:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.