Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am backing up my cPanel server databases with automysqlbackup, in /etc/automysqlbackup.conf I have set: CONFIG_db_exclude=( 'information_schema' 'cphulkd' 'eximstats' 'leechprotect' 'mysql' 'modsec' )

But I am getting the following errors:

###### WARNING ######
Errors reported during AutoMySQLBackup execution.. Backup failed
Error log below..
mysqldump: Got error: 145: Table './eximstats/smtp' is marked as crashed and should be repaired when using LOCK TABLES
mysqldump: Couldn't execute 'show create table `Email-List`': SHOW VIEW command denied to user 'automysqlbackup'@'localhost' for table 'Email-List' (1142)
mysqldump: Couldn't execute 'show create table `object_1`': SHOW VIEW command denied to user 'automysqlbackup'@'localhost' for table 'object_1' (1142)
mysqldump: Couldn't execute 'show create table `object_1`': SHOW VIEW command denied to user 'automysqlbackup'@'localhost' for table 'object_1' (1142)
du: WARNING: use --si, not -H; the meaning of the -H option will soon
change to be the same as that of --dereference-args (-D)

My questions are:

  1. Any ideas why eximstats is not being ignored?
  2. Given I am a non root user (account created with mysql > grant select, lock tables on *.* to 'automysqlbackup'@'localhost' identified by 'password';) how can the other errors be resolved?
share|improve this question
2  
To the down voter - Instead of blindly down voting perhaps you could be more constructive and advise/comment how I could improve my question and help add value to the community –  g18c Feb 24 '13 at 20:49
add comment

1 Answer

up vote 1 down vote accepted

I had a quite similar error and I finally left the default mysql user for automysqlbackup that was for me debian-sys-maint (from /etc/mysql/debian.cnf)

This one had already the proper rights set.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.