Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using dell 2950 server with RHEL 5.3 with XEN kernel default i need to do bonding of my 2 giga nic which i'm using one of the script for that as follow:








alias bond0 bonding
alias eth0 e100
alias eth1 e100
options bonding mode=0 miimon=100

(net*changeing a eth0 to bond0)

but i'm get 16MB/s and i have gigabit switch and cat6 network... if nay one tell me how i can get more speed on my network for copy 500GB on server to other...


share|improve this question
Please remember that depending on the bonding protocol your most likely algorithm will be a src-IP/dst-IP hash to determine which NIC path to use. As such, a single server to server combination will use only one NIC. Unless both ends and the switch support some kind of round-robin scheme, you won't ever use more than 1 Gbps NIC between a single server and another – Kevin Kuphal Jul 30 '09 at 18:43
Thanks for your reply i'm not looking 1G speed when i'm copy from one to other i have lot of .vdx file which we use convirt to install win2k3 and some of the time i have copy exp.vdx from one to other so that time network only 2 server using.. – Rajat Jul 30 '09 at 18:51
/etc/modprobe.conf alias bond0 bonding alias eth0 e100

Are you sure you have that right? E100 is a driver for a 100mbit/s version of Intel network adapters. Are you sure you didn't want e1000? If e100 is the correct driver, it doesn't sound like you have gig nics.

I would use something like ethtool to verify you have gig nics, and that the nics are negotiating to the correct link speed/duplex.

I'm get 16MB/s and i have gigabit switch and cat6 network...

How are you testing? I would suggest that you test with something like iperf to factor out everything other then your network/cpu.

sftp and scp

Also keep in mind that sftp in particular is notoriously slow for file transfers. You should test with something that isn't doing encryption/compression not make sure that you are getting your full throughput. If you really need fast sftp transfers you may need to check HPN-SSH.

if nay one tell me how i can get more speed on my network for copy 500GB on server to other...

If you are not on the Internet consider using something other then scp/sftp for file transfers. For example NFS.

share|improve this answer
I'm using iperf – Rajat Jul 30 '09 at 18:50
I setup a temporary FTP server for this purpose. It was 4x faster tha rsync over ssh – Matt Simmons Jul 30 '09 at 20:01
Zoredache, you're spot-on about the e100 vs e1000; the wrong driver will most likely bottleneck his attempts. +1 for Eagle Eyes in spotting that. – Avery Payne Jul 31 '09 at 7:42

Are you using a gigabit switch that allows packet bursting?

Is your RAID array rebuilding?

Have you tried copying with a single unteamed NIC?

Have you tried copying from dom0 without any domU VM's contending for disk/io?

How are you copying data? (sftp, for examlpe, compresses and encrypts data -- which quickly can become CPU bound, and is single threaded).

If your copying over SSH

Try with FTP/NFS or SCP without encryption enabled. Even HTTP will give a better idea of speed.

share|improve this answer
RAID 5 with out teaming same speed sftp and scp copy paste same speed – Rajat Jul 30 '09 at 18:33

So far you havent mentioned checking actual speeds, duplex, or MTU's. Autonegotiation is great when it works, but often enough it does not. Don't let the defaults screw it up for you, set them up explicitely and it should work. I see sustained 45-50mbytes/sec of samba traffic (which itself is slow) over cheapo builtin gigabit cards between laptops, over a 40$ gb switch.

share|improve this answer
full duplex we r using at both server ! – Rajat Jul 31 '09 at 5:48
Autonegotiation is required for gigabit ethernet according to the standard: – Bob McCormick Aug 3 '09 at 3:57
I've never seen a place use autoneg for gigE connections <shrug> – warren Sep 18 '09 at 11:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.