Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have an entry point from our ISP. It has the subnet 0, it's a MikroTik device over which we have zero control.

We have 2 dumb 4-port switches and 2 wrt54gl routers with DD-WRT installed.

These routers have the subnet of 1 by default, as in, 192.168.1.*. Thus, they give out IPs in that subnet. There are several wall ports throughout the company, so anything connected into those gets a subnet 0 because it basically goes straight to the MikroTik and the huge unmanaged switch it's connected to. I have connected the two WRTs to these wall ports as well, in an attempt to make them APs.

The problem is, the APs give out 192.168.1.* IPs and the rest have 192.168.0.* IPs. Everything on 0 can print, because the printer is also on 0, but the others can't even though they're basically on the same network, since it all goes into the wall ports which go into the MikroTik.

I entered DD-WRT setup and changed the local address to 192.168.0.250 in an attempt to force a 0 subnet, and it works - it gives me a 0.* IP when I connect to it and internet works fine. However, I still cannot see the printer, while others who are connected to it "naturally", without a router in between, can see it and print fine.

What can I do to make the printer appear on my AP's 0 subnet as well?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It sounds like you want the WRTs to act as AP/bridges not routers, and that you already have DHCP running on the 192.168.0 network. If you want your wireless clients on the same network as the wired connections you need to setup the DD-WRT as an AP not a DHCP enabled router. Basically just disable DHCP on the WRTs and connect them via LAN ports instead of WAN ports.

Check out this guide. It walks you through disabling DHCP and using DD-WRT as just a dumb AP. http://www.dd-wrt.com/wiki/index.php/Wireless_Access_Point

share|improve this answer
    
This was it, thanks. Sorry about the slow response, I hadn't had the time to test this before. –  Swader Mar 4 '13 at 23:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.