Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I needed to use a mySQL 5.6 feature (on Ubuntu), so I uninstalled the version I got from apt-get and downloaded and compiled the mySQL 5.6 source code. It installed fine but I can't get mysqld to start. When I run the command sudo /usr/local/mysql/bin/mysqld I get the following output:

2013-02-25 10:03:47 11597 [ERROR] Can't find messagefile '/usr/share/mysql/errmsg.sys'
2013-02-25 10:03:47 11597 [Note] Plugin 'FEDERATED' is disabled.
2013-02-25 10:03:47 11597 [Note] InnoDB: The InnoDB memory heap is disabled
2013-02-25 10:03:47 11597 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2013-02-25 10:03:47 11597 [Note] InnoDB: Compressed tables use zlib 1.2.3
2013-02-25 10:03:47 11597 [Note] InnoDB: CPU does not support crc32 instructions
2013-02-25 10:03:47 11597 [Note] InnoDB: Using Linux native AIO
2013-02-25 10:03:47 11597 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2013-02-25 10:03:47 11597 [Note] InnoDB: Completed initialization of buffer pool
2013-02-25 10:03:47 11597 [Note] InnoDB: Highest supported file format is Barracuda.
2013-02-25 10:03:48 11597 [Note] InnoDB: 128 rollback segment(s) are active.
2013-02-25 10:03:48 11597 [Note] InnoDB: Waiting for purge to start
2013-02-25 10:03:48 11597 [Note] InnoDB: 1.2.10 started; log sequence number 2431209696
2013-02-25 10:03:48 11597 [ERROR] Aborting

And then it prints a bunch of messages about various plugins shutting down. I want to know why it is failing to start, so I am trying to get it to log more specific error messages. I tried creating the file /usr/share/mysql/errmsg.sys but that just made it print other errors when I tried to start it, so I deleted that file again. I looked in /etc/mysql/my.cnf and uncommented the lines that say:

 general_log_file        = /var/log/mysql/mysql.log
 general_log             = 1

And then I created the file /var/log/mysql/mysql.log, chowned it to mysql:adm, and tried starting it again, but it won't write to the file.

Any advice on what to try from here? Thanks!

share|improve this question
    
Is it possible to send your *cnf configuration file ? –  Nikolaidis Fotis Feb 25 '13 at 17:12
    
The error about "/usr/share/mysql/errmsg.sys" seems to be the problem. See askubuntu.com/questions/102875/… –  Mark Wagner Feb 25 '13 at 17:57

1 Answer 1

up vote 0 down vote accepted

Mark Wagner's comment was correct. I was able to fix the problem by running the commands sudo cp /usr/local/mysql/share/english/errmsg.sys /usr/share/mysql/errmsg.sys and sudo chown mysql:mysql /usr/share/mysql/errmsg.sys. See http://askubuntu.com/questions/102875/ysql-5-5-starts-and-then-instantly-stops-on-ubuntu-10-10 for more information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.