Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to follow this guide to prepare my server to become a chef-client: http://wiki.opscode.com/display/chef/Knife+Windows+Bootstrap

When I run commands like:

C:\> winrm set winrm/config @{MaxTimeoutms="1800000"}

I get the following error:

WSManFault
    Message
        ProviderFault
            WSManFault
                Message = There are no more endpoints available from the endpoint mapper.

Error number:  -2147023143 0x800706D9
There are no more endpoints available from the endpoint mapper.

After some investigation I found that this is because the winrm service needs to have windows firewall enabled to make any configuration changes. So I was able to set all the settings except for the one listed above either by command line or using group policy management. The problem is that the company provisioned VM has windows firewall permanently disabled and there is no way to enable it, so I can't increase the connection timeout.

The server is running on Windows Server 2008 R2. Is there anyway I can modify this property by altering registry keys or some other method?

share|improve this question
    
Are they forcing the Windows firewall service to disabled mode? Or are they turning off the firewall for public/private/domain zones? –  SpacemanSpiff Feb 26 '13 at 1:27
    
There is no option to start the firewall service from "Control Panel > Services". When I open up "Windows Firewall with Advanced Security" it says "There was an error opening the Windows Firewall with Advanced Security snap-ip." and the side panels are blank with no options. –  BrandonK. Feb 26 '13 at 1:33
    
It sounds like they're disabling the service entirely. More than likely, they will need to change this approach. In 2003/XP days it was common and easy to just disable the service. In the 2008R2,Windows7/8 operating systems, the recommendation is to disable the firewall for those zones, not disable the service. I do not think you'll work around this otherwise. –  SpacemanSpiff Feb 26 '13 at 1:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.