Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to install Lotus NotesSQL Driver (current version is 8.5) onto a virtual machine running XP. Here's what's I've done so far:

  1. I retrieved the file (CZOWFEN.zip) from the IBM website.
  2. I ran the exe.
  3. I then went to My Computer->Properties->Advanced->Environmental Settings->System Variables->Path and added "; c:\notessql" so the ODBC administrator could find Notes.ini (why the setup file didn't do this in the first place, i don't know).
  4. I opened up the ODBC administrator and tried to add a new System DSN to a Lotus DB.

"The setup routines for the Lotus Notes SQL Driver (*.nsf) ODBC driver could not be loaded due to system error code 126"

  1. I redownloaded and reinstalled the driver (making sure I had the latest version 8.5). No luck.
  2. I checked the registry. All the file paths appeared to be correct.
  3. Per many, many similar cases on the internet, I tried several different variations of adding the various Lotus Notes folders to my PATH variables. Same error.

I've done this setup on 5 different machines now with no problem. The only difference here is that this machine is virtual. Ideas?

share|improve this question
    
What VM software are you running? –  Ken Pespisa Jul 30 '09 at 20:09
    
I believe the name is "VMware tools". –  PowerUser Jul 31 '09 at 14:34
    
"VMware Virtual Platform" –  PowerUser Jul 31 '09 at 14:39

7 Answers 7

up vote 2 down vote accepted

was your notes.ini located in the \Lotus\Notes directory ?... - NotesSQL expects to find Notes.ini in the \Lotus\Notes directory. If the file is not in this directory, the driver may crash when you use the ODBC Data Source Administrator to create a DSN, or the NotesSQL Authentication List Manager may report that it is unable to find a valid version of Notes. If you must place Notes.ini in a directory other than \Lotus\Notes, add the directory to your PATH environment variable.

share|improve this answer
    
Adding "C:\Lotus\Notes\" to the PATH environment variable did the trick. –  PowerUser May 27 '10 at 14:00

The URL for the solution I posted has changed: Convert Notes Data to SQL: http://www.lialis.com/lotussolutionprovider.nsf/pages/convertnotesdatatosql

share|improve this answer

Have you tried this: http://krithikav.wordpress.com/2008/04/10/system-error-126-for-odbc-configuration/

share|improve this answer
    
Thanks for the try, but it doesn't apply. The .dll's are in c:\NotesSQL, not the system32 folder. –  PowerUser Jul 31 '09 at 14:33

what bit depth is the OS? Admittedly it wasn't NotesSQL but we've had trouble in the past with some SQL drivers on 64-bit windows.

share|improve this answer
    
I think it's 32-bit, but I'm not sure. –  PowerUser Jul 31 '09 at 14:41
    
hmmmmmm.... can't remember if NotesSQL is an IBM supported product. If it is perhaps you could raise a PMR with them. –  LRE Aug 2 '09 at 20:00

I found that adding the path C:\Program Files\IBM\Lotus\Notes\ (which is what the registry setting HKLM\Software\Lotus\Notes\Path points to) works for me.

share|improve this answer

Does the NNotes.dll is in the PATH? (if not you need to add it in the path) solved my problem.

share|improve this answer

We have a NOtes2SQL tool which is more than just a driver. Feel free to check our website. http://www.lialis.com/Applications/EnglishSite.nsf/dx/Lialis_Notes2SQL

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.