Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I did a full system update/upgrade on my debian squeeze last night. After this was done, I did a reboot. When proptet with a terminal login screen I tried to login as root, but this failed several times. So I tried as a normal user, this failed as well. (yeah, freaking out for a few seconds)

Then I connected via ssh as a normal user, and this is working. But I cannot su / sudo to root.

Everything was working before the update && upgrade. And I think the only package that got updated was openjpeg or something. And I havent messed aorund with any /etc/passwd or something. (As far as I know)

I tried to boot into recovery mode as root, and this is working, so the password is still the same as ever.

What can I do now?

Ps, I have checked /var/log/auth.log - no update there since May 22 2012 (??) Any other key logs to check? Im going through syslog and dmesg right now. Only way for me to check the logs is to log into recovery mode, and copy the logs to the normal accounts home folder and chmod them.

share|improve this question
    
Does /etc/securetty exist? If so, what does it contain? –  Jenny D Feb 26 '13 at 10:34
    
pastebin.com/wy3tmifb –  Andreas Feb 26 '13 at 10:37
    
Darn. That's one easy solution gone... Next question, then. Can you do "sudo command" instead of just "sudo"? And can you check if there's anything odd in root's .profile or .shrc or whatever root's shell uses? –  Jenny D Feb 26 '13 at 10:38
    
I have to login into recovery mode to check the roots .profile. None of the sudo commands are working. –  Andreas Feb 26 '13 at 10:43
    
When you're in recovery mode would be a good time to look at the syslog config, it'd probably help a great deal if it gives you useable logs. –  Jenny D Feb 26 '13 at 10:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.