Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i try to run postfix version postfix-2.3.3-6 already installed on my CentOS 5.6 server , but it shows FAILED msg when i use this command

/etc/init.d/postfix start

Ok i tried to unveil the source of problem with /var/log/syslog and /var/log/messages but for the first one it says no such file in directory and for the second command another msg says that the permission is denied what should i do ? any suggestion is appreciated

share|improve this question

The permission denied message for /var/log/messages suggests that you're not doing it with root privileges, which in turn makes me wonder if you're not starting postfix as root, either. You will most definitely need to run an MTA as root for it to work.

Try sudo /etc/init.d/postfix start (assuming you use sudo to get root privilege), and if that still fails, try sudo tail /var/log/messages.

Edit: OK, the error message you've found in /var/log/maillog is very likely the indicator of the failure-to-start problem, since it says warning: valid_hostname: misplaced delimiter: u1y3nntoq0. fatal: unable to use my own hostname, and fatal errors are rarely good for software.

Could you find out if there's some issue with a declaration in your postfix config files with grep u1y3nntoq0 /etc/postfix/, and if that doesn't find anything, with find /etc/postfix -type f -exec grep u1y3nntoq0 {} /dev/null \; ? The output of hostname would also be most helpful.

Please edit this output into your question, above, by using the edit link; don't keep adding comments, not least because they destroy the formatting.

share|improve this answer
thanks for reply MadHatter, i have tried sudo /etc/init.d/postfix start but it FAILED! and second give me this message :lookup_read_master: lookup(nisplus): couldn't locate nis+ table auto.master – Omer Stimpack Feb 26 '13 at 15:35
Could we get a few more lines from /var/log/messages than that, say the last ten? If there's a /var/log/maillog could you also give us the last ten lines from that. You should probably edit them into your question, not just post them as a comment. Thanks! – MadHatter Feb 26 '13 at 16:39
The NIS+ error message looks like a messed up /etc/nsswitch.conf (as I assume there is no NIS+ in sight). What does that file contain? – vonbrand Feb 26 '13 at 16:57
Cjay, I've no idea what you just put in there. I asked for the tails of two files, and please edit them into your question, not add them as comments. – MadHatter Feb 26 '13 at 17:46
i put the rest of the msg when i tried sudo tail /var/log/messages – Omer Stimpack Feb 26 '13 at 17:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.