Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When my client try to connect gluster server it gives below error:

[glusterfsd-mgmt.c:1627:mgmt_getspec_cbk] 0-mgmt: failed to fetch volume file (key:gluster_vol_0)

My client is an Amazon Linux instance located on Anazon EC2. I installed glusterfs-fuse like below:

sudo su -

#install glusterfs repo
wget -P /etc/yum.repos.d http://download.gluster.org/pub/gluster/glusterfs/LATEST/EPEL.repo   /glusterfs-epel.repo
#fix it for amazon linux
sed -i 's/$releasever/6/g' /etc/yum.repos.d/glusterfs-epel.repo 

#install glusterfs
yum install -y glusterfs-fuse

#setup fstab
echo "hostname.example.com:/media-volume /mnt/glusterfs glusterfs defaults 0 0" >> /etc/fstab

#mount
mkdir -p /mnt/glusterfs
mount -a

Could you help me please.

Kind regards...

share|improve this question
    
I'm currently having the same issue on Ubuntu 12.04 LTS. If I find a solution, I'll post it here. –  Brian Knight Mar 1 '13 at 16:17
add comment

1 Answer

I experienced the same error (missing key) when installing Glusterfs-server 3.3.1 today. My resolution was to manually install the same version on the client side, as the repo offered me an older version than 3.3.1.

Atleast it fixed it in my case using Debian 6 as server and Ubuntu 12.04 as client.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.