Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have recently setup a Centos 6.3 VPS running ISPConfig3 and Webmin with Nginx as the web server and BIND as the DNS server. This is the first time I've tinkered with ISPConfig, Webmin and Nginx.

I did have it all up and running however needed to reboot it the other day. So far I've not been able to get any domain names to resolve to it since the reboot. I've run through all the firewall settings, confirmed the DNS zones checked the nameservers etc with no luck.

I can access ISPConfig and Webmin via the server IP address, I can SSH into the server via the IP, and dig returns noerror for both nameservers either from my local computer or from the server:

dig ns3.terraserve.com.au

; <<>> DiG 9.8.3-P1 <<>> ns3.terraserve.com.au
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6408
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ns3.terraserve.com.au.     IN  A

;; ANSWER SECTION:
ns3.terraserve.com.au.  9685    IN  A   203.143.83.245

;; Query time: 26 msec
;; SERVER: 192.168.2.1#53(192.168.2.1)
;; WHEN: Wed Feb 27 14:24:26 2013
;; MSG SIZE  rcvd: 55

This has got me a bit stumped given it was all running perfectly fine before the reboot.

The domain is terraserve.com.au and the nameservers are ns3.terraserve.com.au and ns4.terraserve.com.au.

Going to terraserve.com.au should show an Nginx index.html file at present.

Any ideas to point me in the right direction would be greatly appreciated!

share|improve this question
2  
Please don't use Webmin/cPanel/ISPConfig/etc. They obfuscate what is actually going on, make it difficult or impossible to troubleshoot, and do things in non-standard ways. Just buckle down and learn proper Linux administration. –  EEAA Feb 27 '13 at 4:49
    
Your query appears fine. Exactly what is the problem? You may need to disclose the actual host/domain name having the issue... –  Michael Hampton Feb 27 '13 at 5:18
    
EEAA, Webmin came provisioned with the VPS, I've only used it thus far for verifying I can access it. Everything else was setup via SSH. We do however need a frontend as it is going to run a couple of websites where clients need basic email and database admin functionality but not SSH access. –  Matt Feb 27 '13 at 8:37
    
Michael, that's the problem the query is fine. However, browsing to the primary domain or to any other domain that is pointing to it fails to resolve. I've updated it with the domain, nameservers and IP address. I hope that helps, thanks for your help. –  Matt Feb 27 '13 at 8:39
    
May be you are having same problem as I had and got it solved here -> serverfault.com/questions/482747/… –  tenzin Feb 27 '13 at 20:54
add comment

1 Answer

up vote 0 down vote accepted

OK, you have two major issues here:

  1. Your host 203.143.83.245 does not respond to DNS queries or even to pings. Since this is the only listed nameserver for your domain, it is therefore impossible for anyone to resolve any records in your domain.

    I see, however, that it does respond on port 22, which indicates that you have misconfigured your firewall. Fix the firewall configuration: You need to allow inbound port 53 on UDP and TCP; and it's also a good idea not to block ICMP (as you have).

  2. You only have one nameserver. You cheated by assigning two hostnames the same IP address. This is a bad idea because if the single nameserver has a problem, there is no backup. (RFC 2182)

share|improve this answer
    
Thanks Michael, port 53 on UDP and TCP is allowed, ICMP however was not, I have added this to IPTables however am still seeing the same issue. I have just tried disabling the CentOS firewall and all runs as it should, so you are right it definitely is a firewall issue. I've enabled the ISPConfig firewall instead at the moment and all still appears to be running, so I will have to have experiment with the IPTables configuration further. We are planning on adding a second IP for the second hostname once I've got the hang of this, I'm starting to think it may be easier to just add it now though. –  Matt Feb 27 '13 at 9:47
    
Thanks for your help Michael, I appreciate it, I know where I'm looking for the problem now! –  Matt Feb 27 '13 at 9:48
    
It doesn't help if the second nameserver is on the same physical machine or local network. It should be on an entirely separate network. –  Michael Hampton Feb 27 '13 at 9:48
    
That makes sense. I'm having a read through of the RFC 2182 now and will have a look into this further. Thanks again for your help and advice. –  Matt Feb 27 '13 at 11:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.