Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

hello there are some laptops running ubuntu 8.1 with NetworkManager, which on startup automatically connects to the strongest wireless network. i need to disable this for security reasons, so a connection will occur ONLY if the user starts a connection. i tried looking all over the internet and couldn't find a solution, nothing worked, and i don't see any configuration option for this. hwo do i disable auto-connect?

share|improve this question

2 Answers 2

Personally I find that the Gnome NetworkManager is a bit broken myself. I tend to recommend using the wicd wireless network manager instead.

Wicd Project Page: http://wicd.sourceforge.net/

Wicd will, by default, not automatically connect to the strongest AP. It remembers each AP and allows you to set up wireless profiles for them if you like, but YOU have to opt-in to autoconnect to any of them or not.

There is also has the pleasant side affect of wicd uninstalling the default NetworkManager, a nice touch in my opinion! ;-)

share|improve this answer

Maybe disabling roaming mode will help?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.