Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm configuring TFS 2012 in advanced mode, that means that Sql Server is on another machine. When I need to specify the database server (in the TFS Configuration) it fails because the SqlServer host is unreachable.

TFS255049: A connection cannot be made to the server that is running SQL Server. Verify
that you have entered the correct name for the server, including the instance name,
that the server you are attempting to connect to is online, and that you have the
required persomissions to connect. If you are attempting to connect to the remote SQL
Server instance, then verify that it is configured to allow remote connections, that
TCP/IP protocol is both enabled and configured to use port 1433 (default), and that
Windows Firewall does not block this port.

Also, when I ping to databaseserver, the ping fails.

But if I remove the databaseserver from the domain, then the configuration doesn't fail in that step (the databaseserver is accesible) but, obviously, it fail in next steps (because the of account that is needed to authenticate to SqlServer, databaseserver MUST be joined to the domain).

What am I missing?

EDIT

The gpresult file looks like this (it's in spanish, hope it won't be a problem...)

Denied GPOs 
       Default Domain Policy
           Ubicación de vínculo               pinard.local
           Extensiones configuradas  
           Exigido                                No
           Deshabilitado                          Ninguno
           Filtros de seguridad               NT AUTHORITY\Usuarios autentificados
           Revisión                               AD (0), SYSVOL (0)
           Filtro                                 WMI    
           Causa denegada                         Vacío
      Local Group Policy
           Ubicación de vínculo               Local
           Extensiones configuradas  
           Exigido                                No
           Deshabilitado                          Ninguno
           Filtros de seguridad  
           Revisión                               AD (0), SYSVOL (0)
           Filtro WMI    
           Causa denegada                         Vacío
share|improve this question
    
How does the firewall configuration look when domain joined, and are you pinging the fully-qualified name? –  Greg Askew Feb 28 '13 at 13:09
    
the firewall configuration remains the same. Pinging the fullqualified name, the IP, or the NetBIOS doesn't make a difference. –  Agustin Meriles Feb 28 '13 at 14:57
    
If you cannot ping the IP address - implying no network connectivity to the SQL server - there would be something fundamentally wrong. –  Greg Askew Feb 28 '13 at 15:10
    
The funny thing is that when I "detach" the databaseServer from the domain, then the ping and the connection to the SqlServer works fine. The installation of the windows 2012 in databaseserver is clean. May be some policies configuration in the Domain controller be involved? –  Agustin Meriles Feb 28 '13 at 15:16
    
Have you reviewed the group policies? It's fairly easy to create a report using: gpresult /h gpresult.html –  Greg Askew Feb 28 '13 at 16:29

1 Answer 1

up vote 1 down vote accepted

I hit this same error. On the SQL Server, try opening the port for SQL traffic. That's what I did. Here is a blog post I did on this.

http://elhajj.wordpress.com/2013/02/25/workaround-error-tf255049-punching-a-hole-through-windows-firewall/

In Windows Firewall, you can define ports based on how you identify a network to the OS, which might account for why it works on workgroup/non-domain. By default, all networks are set to disallow incoming packets.

Good luck

share|improve this answer
    
Thanks man It worked perfectly! –  Agustin Meriles Mar 4 '13 at 11:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.