Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

First let me describe my setup. I have a virtualised server with one VM for ispCP where I host a bunch of websites. Email for these websites is hosted through Google Apps.

The problem I have is that if I try to send an email from this server (such as from a PHP contact form) to one of the Google Apps email accounts it never arrives but it does arrive if I send it to an email address that does not have a website on the server (e.g. a GMX account).

Looking around, this problem seems to be caused by emails being routed internally. I have looked around but I can't seem to find any simple, clear solution.

I am running on Debian 6 64bit with ispCP and postfix.internal routing postfix

share|improve this question
add comment

1 Answer

I have not used ispCP myself, but the general solution in this case is to disable local mail hosting for the domain.

According to this link, this can be done in the GUI:

  • switch to the user (dom.tld)
  • delete all mail accounts
  • switch back to the corresponding reseller
  • change the domain, set the numer of mail accounts to -1 (disable)
  • change the traffic limit -> ok
  • if needed: change the domain, set the traffic limit back to the previus number

this way the domain is removed from the domain hashfile (the mportant thing is the change of the transfer volume).

Note by BT: The traffic limit trick is needed to invoke the ISPCP Engine, which updates the domains.

share|improve this answer
    
I don't think that this could be the problem as the domain already has email disabled in ispCP. –  camerongray Feb 28 '13 at 14:17
    
then why do you write "caused by emails being routed internally"? If the mail hosting is really disabled messages would be sent to the mx record and not be routed internally. A mail log snippet of such a message would probably provide clarity of what happens. –  Gryphius Feb 28 '13 at 15:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.