Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm setting up a web server on an old OpenBSD machine, and am getting an error each time I try to start Apache. The server refused to start after I added my virtual host with HTTPS.


could not resolve host "" port "https" --- no address associated with name
usr/sbin/apachectl start: httpd could not be started

Virtual Host Configuration

My virtual host configuration is below (/var/www/conf/vhosts/[file].conf)

Listen https

<VirtualHost *:80>
   ServerName [url]
   DocumentRoot /var/www/[url]/public_html

   ServerName [url]
   DocumentRoot /var/www/[url]/public_html
   ErrorLog /var/www/[url]/error_log
   TransferLog /var/www/[url]/access_log
   SSLEngine on
   SSLProtocol all -SSLv2

   SSLCertificateFile /var/www/[url]/ssl.crt
   SSLCertificateKeyFile /var/www/[url]/ssl.key
   SSLCertificateChainFile /var/www/[url]/[ca.pem]
   SSLCACertificateFile /var/www/[url]/ca.pem
   SSLCACertificateFile /var/www/[url]/ca.pem
   <Directory "/var/www/[url]/public_html">
              AllowOverride All

Network Details

I'm running behind a firewall with a dynamic IP address.
I have an A record pointing to my dynamic IP address.
In the firewall, port 80 and 50720 (along with others) are pointed at my local IP address ( statically assigned via MAC address in DHCP

Other Attempts

I've used wildcard IP addresses (Listen *:50720 https), and get the same error

Has anyone encountered this before? I didn't find much on Google with this error message (apache "could not resolve host" "no address with name", etc.)
I'm happy to give more details if it would help.


  • [url] is [subdomain].[subdomain].[domain].us. I have an A record pointing to my dynamic public IP address.
  • I have not edited my /etc/hosts file, I have not had to do that on any server before when setting up virtual hosts (including ones with SSL)
share|improve this question
The message is confusing as port "https" should not imply a port (which would be 443 by default, not 50720) but a protocol. As a try, I woould associate the servername with th eip in /etc/hosts and then (also) try with Listen 50720, Listen [url]:50720 (and with httpsadded if that is really required) – Hagen von Eitzen Feb 28 '13 at 22:30

Since you're running 1.3, the first advice is to upgrade it.

The second is that the docs for 1.3 are still available, though not exactly publicized, as that is a very outdated version with security holes in it. But the docs are at

The third - the problem here is that 1.3 does not allow you to state a module on the Listen line as 2.4 does. So the line should look like this:


I also note that in your config above, you have one VirtalHost on *:80. You will need to have a Listen directive for each port on which you're running a VH, but maybe you already do and I've missed it. You've probably also got some other directives in your config file that won't work with 1.3, and that's why it's not starting.

And lastly, information about how to upgrade packages on OpenBSD is available in the OpenBSD FAQ.

share|improve this answer
It's for my SSL secured vhost: – Ryan Leonard Feb 28 '13 at 20:43
OK, I see what you mean. This is a change between 2.2 and 2.4 and you didn't specify which version you're running. – Jenny D Feb 28 '13 at 20:46
oh, I don't even know what version I'm running, I just used the latest documentation anyways :) – Ryan Leonard Feb 28 '13 at 20:48
Then it'd be a great idea to start by finding that out. It'll make it a lot easier to help you. – Jenny D Feb 28 '13 at 20:50
Version 1.3.29. I tried removing the https, and got httpd could not be started. (I'm used to just grabbing apache from a yum repo, so I don't even think about having an old version) ServerName is [subdomain].[subdomain].[domain].us – Ryan Leonard Feb 28 '13 at 20:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.