Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I configured Postfix, after a time I discovered I am blocked from sending emails because my network is on a blacklist (it's a dynamic IP). So, sometimes Outlook does not connect to send (still gets the mails). Then I changed the SMTP on the master file and I set port 587 on this way:

587      inet  n       -       -       -       -       smtpd

The problem is now I can't receive, I get these errors:

The recipient server did not accept our requests to connect

On my domain manager I set the A register to point to his own IP, and the MX to point to my domain name (the MX is mydomain.com, not mail.mydomain.com, but all was configured this way with Postfix).

I don't understand what could be wrong, any idea of this issue?

share|improve this question
    
Probably, outer SMTP servers or relays merely don't know how to connect to your SMTP server. Maybe they try to connect to port 25. You can clear it out by issuing tcpdump -nnn -i ethX port 25. Then try to send e-mail to your domain from another ISP. If there will be any output, then I'm right. –  slimsuperhero Mar 1 '13 at 6:03
    
it returns (SIOCGIFHWADDR: No such device) –  user156355 Mar 1 '13 at 15:14
    
You should be root or run sudo tcpdump -nnn -i ethX port 25. And do not forget to replace ethX with actual name of your WAN interface, e.g. eth0 or eth1 or anything-you-have. –  slimsuperhero Mar 1 '13 at 15:38

1 Answer 1

up vote 8 down vote accepted

To receive emails from other servers, you need to be listening on port 25. Port 587 is the submission port, intended for clients to submit mail for delivery. Other mail servers will never try to connect to this port.

share|improve this answer
    
Thanks for the answer....do u know how do enable this listening? –  user156355 Mar 1 '13 at 14:48
    
@user156355 - you undo what you did to switch to port 587. –  EEAA Mar 1 '13 at 16:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.