Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried Below 2 packages,but both were faled. I even tryed to install missing dependencies, but that also again asking some another dependencies. Is there any other approch to install skype on Debian 6 ?

skype-debian_4.0.0.7-1_i386.deb
skype-ubuntu-lucid_4.1.0.20-1_i386.deb

Error Detail of 1st package:

root@debian:~/skype-install# dpkg -i skype-debian_4.0.0.7-1_i386.deb
Selecting previously deselected package skype.
(Reading database ... 56273 files and directories currently installed.)
Unpacking skype (from skype-debian_4.0.0.7-1_i386.deb) ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libqt4-dbus (>= 4:4.5.3); however:
  Package libqt4-dbus is not installed.
 skype depends on libqt4-network (>= 4:4.5.3); however:
  Package libqt4-network is not installed.
 skype depends on libqt4-xml (>= 4:4.5.3); however:
  Package libqt4-xml is not installed.
 skype depends on libqtcore4 (>= 4:4.6.1); however:
  Package libqtcore4 is not installed.
 skype depends on libqtgui4 (>= 4:4.6.1); however:
  Package libqtgui4 is not installed.
dpkg: error processing skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 skype
root@debian:~/skype-install#

Error Detail of 2nd package:

root@debian:~/skype-install# dpkg -i skype-ubuntu-lucid_4.1.0.20-1_i386.deb
Selecting previously deselected package skype.
(Reading database ... 56273 files and directories currently installed.)
Unpacking skype (from skype-ubuntu-lucid_4.1.0.20-1_i386.deb) ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libqt4-dbus (>= 4:4.5.3); however:
  Package libqt4-dbus is not installed.
 skype depends on libqt4-network (>= 4:4.5.3); however:
  Package libqt4-network is not installed.
 skype depends on libqt4-webkit (>= 4:4.5.3); however:
  Package libqt4-webkit is not installed.
 skype depends on libqt4-xml (>= 4:4.5.3); however:
  Package libqt4-xml is not installed.
 skype depends on libqtcore4 (>= 4:4.6.1); however:
  Package libqtcore4 is not installed.
 skype depends on libqtgui4 (>= 4:4.6.1); however:
  Package libqtgui4 is not installed.
dpkg: error processing skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 skype
root@debian:~/skype-install#
share|improve this question
    
Why didn't you install the dependencies? –  Michael Hampton Mar 1 '13 at 10:04
    
Hi @MichaelHampton , Tried to install one by one , but it intern asking some other dependences ,, Something look like an endless process .. –  Arun Mar 6 '13 at 10:41

1 Answer 1

Unfortunately, apt does not have any means of installing locally downloaded packages so you can't take advantage of its dependency resolution and dpkg doesn't have dependency resolution. So you are in a catch-22 here.

The solution is to use gdebi to install the package. It will resolve the dependencies, install them, and finally install your locally downloaded package. (If you don't want the GUI, then install gdebi-core.)

apt-get install gdebi-core
gdebi skype-debian*.deb
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.