Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying to make the package unattended-upgrades running under Debian GNU/Linux (7.0) with no success so far.

The steps I have followed:

  • Install unattended-upgrades
  • Enable it

    sudo dpkg-reconfigure -plow unattended-upgrades
    
  • Uncomment the following lines in /etc/apt/apt.conf.d/50unattended-upgrades

    "o=Debian,n=wheezy";
    "o=Debian,n=wheezy-updates";
    "o=Debian,n=wheezy-proposed-updates";
    "o=Debian,n=wheezy,l=Debian-Security";
    
  • Wait two days

It's supposed to run every day, but it did nothing by the time. I've checked its logs at /var/log/unattended-upgrades/ and apt history log at /var/log/apt/history.log but nothing happened there since the installation.

Is there any step I am missing to enable it? After reading the doc under /usr/share/doc/unattended-upgrades/README, I think that the above are the only ones you have to follow to get it running.

share|improve this question
1  
What is the value of APT::Periodic::Unattended-Upgrade (probably set in /etc/apt/apt.conf.d/10periodic)? –  Steven Monday Mar 1 '13 at 13:59
    
In my case, it's set in /etc/apt/apt.conf.d/20auto-upgrades and its value is "1". –  Fredrik Mar 1 '13 at 16:13

1 Answer 1

Try this:

Unattended-Upgrade::Origins-Pattern {
        "o=Debian,a=testing";
        "o=Debian,a=stable";
        "o=Debian,a=stable-updates";
        "o=Debian,a=proposed-updates";
        "origin=Debian,archive=stable,label=Debian-Security";
};

The file /etc/apt/apt.conf.d/20auto-upgrades must contain:

APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Unattended-Upgrade "1";
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.