Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have several Supermicro servers, and I can't connect to any of their KVM's through IPMI anymore; I keep getting 'connection failed'. I first noticed it with one, but trying others resulted in the same error.

I tried:

  • Browser plugin (firefox+java7) on Windows server 2008.
  • Browser plugin (firefox+java7) on Windows 7.
  • Browser plugin Mac+safari+java7.
  • Browswer plugin Linux+openjdk-1.7+icedtea plugin.
  • stand-alone ipmi tool on Windows server 2008 (Supermicro's ipmiview).
  • stand-alone IPMI tool on Linux openjdk 1.6 and 1.7 (Supermirco's ipmiview).
  • resetting the IPMI controller (which is sometimes necessary because it crashes): ipmitool mc reset warm.

I keep getting 'connection failed', no matter what I try.

I did a tcp dump and analyzed it with wireshark, and all I see is that a SYN is sent by the client, and a [RST, ACK] is received, which wireshark marks red.

I used the console a lot in the past, so I don't know what is the problem here. I read something about java 1.6 (java 6) working, but that did not seem to help me.

Edit: it's not a network issue, because I can connect to the webadmin and control everything but KVM. I can even see the screenshots of the booted OS.

And some info:

# ipmitool mc info
Device ID                 : 32
Device Revision           : 1
Firmware Revision         : 2.0
IPMI Version              : 2.0
Manufacturer ID           : 47488
Manufacturer Name         : Unknown (0xB980)
Product ID                : 1541 (0x0605)
Product Name              : Unknown (0x605)
Device Available          : yes
Provides Device SDRs      : no
Additional Device Support :
    Sensor Device
    SDR Repository Device
    SEL Device
    FRU Inventory Device
    IPMB Event Receiver
    IPMB Event Generator
    Chassis Device
Aux Firmware Rev Info     : 


On my Linux machine, I use IPMIView-2.9.15-build121211-bundleJRE-linux, and even when using the included JRE (./jre/bin/java -jar JViewerX9.jar host ADMIN password), it doesn't work. Maybe it is a network issue, but I didn't change anything on our router/firewall (Debian Linux machine).

share|improve this question
Is there a firewall between client and BMC? Which are your "dedicated"/"shared"/"failover" NIC settings? Is your "standalone IPMI tool" a current IPMIView or something different? What BMC firmware is in use (hint: Do not gratuitously update, I had a lot of fun with 2.66 and the web KVM client malfunctioning with current java, where older versions work)? EDIT: scratch the bit wrt the NIC settings if you can connect to the BMC at all. –  rackandboneman Mar 1 '13 at 15:24

2 Answers 2

up vote 3 down vote accepted

What do you know; when I did ipmitool mc reset cold, it did work again.

The only problem is, that I can't do this on the machine I lost the connection to...

share|improve this answer
Actually, there was a reset option in the web GUI that did still work. –  Halfgaar Mar 2 '13 at 14:12

IPMI KVM (X9DRD-if motherboard, SuperMicro server)


  • Macbook + Chrome + Java7 at home connected by wifi to a ROUTER WITH STATIC IP
  • Windows 7 + IE7 + Java7 at home connected by LAN in a ROUTER WITH STATIC IP
  • Linux Virtual Machine + Firefox inside MacBook at home connected by wifi to a ROUTER WITH STATIC IP

IT DIDN'T WORKED WITH (connection failed, every time)

The same Macbook with any of IE/Chrome/Firefox + Java6/7 connected TO THE UNIVERISTY'S CAMPUS WIFI


It is not the OS, the browser or the java version which is faulty, it is your router's configuration or other network settings.


Change network. If you are at work/university/place_with_fancy_wifi and can't access other internet network(s), run the java JVM at home or somewhere with a static IP, and connect by TeamViewer or VPN to your home to control your server.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.