Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a very frustrating time configuring the IPMI interface on a Supermicro box.

Unfortunately with IPMI it is not always clear which interface is being used by the BMC. The Supermicro Embedded BMC Manual says that the active interface is determined during the initial power up:

Note 1: If you wish to use the IPMI-dedicated LAN port for your network connections, be sure to connect an RJ45 cable to your dedicated LAN port before you activate the BMC (at first power-on or cold reset). Otherwise, the BMC will look for a shared LAN port to connect to if the IPMI-dedicated LAN cable is not detected upon BMC activation.

  1. Can I use ipmitool to tell if this system is using the IPMI-dedicated LAN port or the shared LAN port?
  2. Can I use ipmitool to see if the link is up? For comparison, it is easy to see if a link is up on linux -- simply use ifconfig or ip addr and look for the 'UP' flag. Is there an equivalent with ipmitool?

Some details:

  • I wasn't here when the system was powered on. I cannot powercycle the system right now.
  • There is an Ethernet cable plugged into the dedicated IPMI port, the link light is on and ipmitool lan print 1 shows a static IP is assigned. But the BMC is not responding to ping.
  • I've tried ipmitool bmc reset cold and reconfiguring the BMC with a new IP and it still doesn't work.
  • I suspect that the BMC is using the non-dedicated LAN port 0 (e.g. 'eth0' the first LAN port used by the host). This is incorrect -- that port is in use by the host and is connected to a public LAN.

** Update **

The ipmitool man page says that lan get can be used to display this information, but lan get active does not work:

% ipmitool -I lanplus -H 172.16.100.100 -U ADMIN -P secret lan get active
Invalid LAN command: get
%
share|improve this question
    
FWIW, we have the same issue when we give power to the computer before plugging in the ipmi network interface. We've only been able to recover by unplugging the server, waiting awhile and plugging it back in :( –  kormoc Mar 1 '13 at 21:22
    
Yes I've discovered the same thing. See my other answer here: serverfault.com/a/370297/36178 –  Stefan Lasiewski Mar 1 '13 at 21:40
1  
I've been able to avoid the unplug/wait/plug cycle with commands like ipmitool bmc reset warm and ipmitool bmc reset cold. –  Stefan Lasiewski Nov 12 '13 at 18:16
add comment

1 Answer

I've had lots of trouble with BMC as well. If you don't succeed with the ipmitool, your best bet is to get direct access to the machine somehow so you can setup a static IP in the BIOS of that machine. Trust me, doing it this way saves you A LOT of trouble.

Once the IP is set statically, it should be accessible from outside or wherever you can ping the BMC from. Using DHCP proved a bit too unstable for productive environments for my taste.

So do it while setting up the machine in the rack and save yourself hours of work by spending some minutes in the first place. ;)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.