Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Main Workflow:

When you are physically on computer A (with a large resolution) and remote desktop (with the sub workflow) into computer B and then remote desktop again to computer C with a very large resolution on computer B. Then physically go over to computer B (with a smaller resolution than computer A) and remote desktop (with the sub workflow) into computer C again, the Windows Remote Desktop client remembers the window size and can't reset it. It's specific to the host you connect to. When you physically log onto computer B and remote desktop using the sub workflow below, how do you correct this issue described after "NOTICE:"?

Sub-Workflow:

Windows Start menu > Run > type "mstsc" > click "Connect" on "Remote Desktop Connection" dialog > click "Connect" on "Do you trust this remote desktop connection?" > (NOTICE: remote machine maximized window is smaller than your local machine Windows operating system monitor screen)

share|improve this question

closed as not constructive by joeqwerty, EEAA, Dave M, Khaled, mdpc Mar 7 '13 at 2:03

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 0 down vote accepted

This new sub workflow should fix this issue:

Windows Start menu > Run > type "mstsc" > click "Options" on "Remote Desktop Connection" dialog to expand the options > click "Display" tab > check and uncheck the checkbox labeled "Use all my monitors for the remote desktop session" > click "Options" on "Remote Desktop Connection" dialog to collapse the options > click "Connect" on "Remote Desktop Connection" dialog > click "Connect" on "Do you trust this remote desktop connection?" > (NOTICE: remote machine maximized window is the same size as your local machine Windows operating system monitor screen)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.