Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using vsftpd 2.2.2 behind the NAT.

To make it work, I set pasv_address to my external (internet) IP. Now the problem is with clients that connect it through the LAN - they try to connect to the passive IP advertised by server and obviously fail.

I know that some ftp clients can be configured to ignore the advertised address, but not all of them unfortunately.

How can this be solved?

share|improve this question
add comment

1 Answer

There some alternative solutions:

  1. If possible in vsftpd, use different config for LAN and other. May be two different instance of vsftp.

  2. Add src-nat for dst-nat connections on router internal ip

  3. Use for server different from internal clients IP subnet.

PS. I quickly look at vsftpd config manual. It not possible to use different configuration for different client IP.

share|improve this answer
    
Can you hint how to provide two configs to vsftpd? two instances of vsftpd does not sound like a good option. –  Zaar Hai Mar 4 '13 at 13:36
    
I quickly look at vsftpd config manual. It not possible to use different configuration for different client IP. Use option 2. or 3. –  mmv-ru Mar 4 '13 at 14:19
    
Unfortunately my server runs on AWS EC2. So I do not have access to NAT rules. The only doable option is to try using the Route53 service to implement split DNS technique. –  Zaar Hai Mar 4 '13 at 14:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.