Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The ZFS dump device is used only for debugging problems. In this case, I have decided the risk vs reward is such that I should delete the dump device to make room for other storage.

I am able to disable save-core (copy from dump device to /var/crash) using dumpadm -n, but when I run zfs destroy rpool/dump, I still get
cannot destroy 'rpool/dump': dataset is busy, indicating that dumpadm -n was insufficient.

How can I disable and remove this dedicated dump device?

share|improve this question
up vote 1 down vote accepted

Specify another location for dumpadm to use crash dumps instead of just disabling them.

dumpadm -d swap


share|improve this answer
This won't work for me because I removed the swap device to save disk space. There was so much free RAM that swap could not have improved performance. – George Bailey Apr 22 '13 at 20:24
I haven't tried this myself, but if you read the link it suggest that even you don't have a suitable swap device, telling it to use swap will set it to 'none' so it's no longer using your dump device. Can't hurt to try. – notpeter Apr 26 '13 at 2:36
I already tried. It didn't work. – George Bailey Apr 26 '13 at 12:47
Since you're just trying to reclaim the space, can you resize the dump volume to something silly small like zfs set volsize=1M rpool/dump? – notpeter Apr 26 '13 at 16:50
Yep. That silly solution seems to be the best I can do. – George Bailey Apr 26 '13 at 20:59

According to:

zdb -d tank | grep rpool/dump

and now zfs destroy found datasets.

share|improve this answer
I might give it a try next time I'm working on a staging server, but at first glance it looks like the linked page is solving dataset already exists, while my question is about dataset is busy. So maybe it will work and maybe it won't... – George Bailey Jun 11 '14 at 21:57
This looks like a very helpful command. I have an idea on how zdb could make my reporting scripts more accurate. – George Bailey Jun 11 '14 at 21:59
Doesn't seem to work. No results output from the command. – George Bailey Dec 3 '14 at 1:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.