Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Whenever I receive upgraded packages from, I get the following error:

WARNING: The following packages cannot be authenticated!
  apache2 apache2-mpm-prefork apache2.2-common ...
Install these packages without verification [y/N]? 
E: Some packages could not be authenticated

I'm running Debian 6 in an OpenVZ container. I have the following line in my /etc/apt/sources.list:

deb squeeze updates/main updates/contrib

I have debian-archive-keyring installed and up to date.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The sources.list template coming with OpenVZ is misconfigured. Run the following to correct it:

sed -i ' squeeze updates/main updates/ squeeze/updates main non-free contrib#' /etc/apt/sources.list
apt-get update
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.