Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have setup a DFS system as follows.

Office 1 (10MB Leased Line) SBS 2003 Server - Runs the network Windows 2008 Standard Server - Member Server + DFS Services (Namespace server)

Office 2 (4 x Bonded Broadband Lines) Windows 2008 Standard Server - BDC + DFS Services (Namespace server)

If i log on to any server and browse the DFS shared folder I can create a file and watch it replicate almost immediately across to the other office DFS share. Accessing the shares is pretty instant even across the broadband links.

On the network PC's at office 1, they are connected to the LAN at 100mb and have created shortcuts to the shared area on their desktop. When they try and browse the shares their response is incredibly slow, 2 mins for a folder list of shares etc.

They can browse \servername quickly and view shares quickly but when accessing the shared namespace url and the shared folders it is very slow for some reason. Any ideas why this is?

The clients can still access the SBS2003 server shares instantly without an issue. The load (cpu/disk/network counters in resource manager) seems fine on both DFS servers too.

Also if anyone knows any tools for DFS to see live what is being replicated/queued up that would be great to use to see if the broadband links are causing a large bottleneck.

Thanks

share|improve this question
add comment

2 Answers

The DFS client uses AD sites to lookup the closest link. Do you have your sites and subnets properly setup in AD?

share|improve this answer
    
i will double check the AD Sites n Services to see if everything is setup okay. thanks –  user3943 Jul 31 '09 at 11:46
    
Settings double checked and all appear to be fine. One site per office, each has their own subnet, regular replication, seems fine. –  user3943 Jul 31 '09 at 11:58
    
Are you using XP SP2? Have you seen support.microsoft.com/kb/915377 ? –  chankster Jul 31 '09 at 12:58
    
Yes I have seen that KB article, the computers are running XP Pro 32bit SP3. I have just tried to download and apply that hotfix and got a message to say SP3 already includes the fix. Its a shame because those issues that it talks about are pretty much exactly the issues I am getting with it... –  user3943 Jul 31 '09 at 13:24
add comment

I would check your referral settings in the namespace of which you're having the problem.

Open up DFS managment, and select your namespace. Click the "Namespace Servers" tab, and select one. Click Properties, and on the Advanced tab, make sure that the referral isn't being overridden to something like "Last among all targets".

Then go to your folder targets, and do the same thing, to ensure that the referral is set correctly.

Your clients can navigate to the slow folder, right click in the white space and choose properties, and click the DFS tab. This will show which server is providing the referral for the folder target. It should help in troubleshooting. If you do it from the top of the namespace, it will show you which namespace server is providing the referral.

share|improve this answer
    
I have checked the overide settings as you suggest and these are all set as default and do not have any setting overidden for the namespace servers or the folder targets. When i right click and get the DFS tab up from a PC in office 1 then i can see the following: office 1 server 2008 - Active=Yes - Okay office 2 server 2008 - Active=No - Okay I get the same results for machines at Office 2 - however strangely enough the machines at office 2 all access the server at office 2 quickly as normal without the speed issues. –  user3943 Jul 31 '09 at 14:57
    
So all clients say Office 1 server is active, but only Office 1's access is slow? That is almost the exact opposite of what we would expect, because it sounds like Office 2 is accessing the Office 1 server. IS this a domain-based namespace, with multiple sites, across a VPN link? –  Jeff Miles Jul 31 '09 at 15:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.