Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running the MindTouch Core 10.1.3 CMS web application on a 2008 R2 server and am running into issues. I have posted the issue over on those forums as well (haven't received a response yet), but I think the issue is more related to the web server and networking since the problem doesn't happen locally.

Basically, every few hours or so, we will receive an HTTP error 500 message either in the browser or in the logs. This happens when browsing pages and is especially reproducible when uploading files (usually between 5-10MB). Simply refreshing the page or trying to upload the file again will allow it to eventually complete.

In IIS, I see several entries of the following under FailedReqLogfiles:

ModuleName ManagedPipelineHandler 
Notification 128 
HttpStatus 500 
HttpReason Internal Server Error 
HttpSubStatus 0 
ErrorCode 0 
ConfigExceptionInfo  
Notification EXECUTE_REQUEST_HANDLER 
ErrorCode The operation completed successfully. (0x0) 

The PHP version is 5.2.14 (version that ships with MindTouch). I will also see some entries in the PHP error log that show:

[05-Mar-2013 15:03:31] PHP Warning:  implode() [<a href='function.implode'>function.implode</a>]: Invalid arguments passed in C:\Program Files (x86)\MindTouch\MindTouch\web\skins\error-settings.php on line 93

The server is a virtual machine with 4GB RAM and 4 vCPUs. It is hosted in the cloud and accessible over the web.

What things can I look at to troubleshoot this issue? Are there settings on the properties of the App Pool that I should review? Any help is greatly appreciated.

share|improve this question
    
I think this reflects a problem in the PHP process somewhere. ManagedPipelineHandler seems to be handing the request off to PHP, which is lunching itself. –  TristanK Mar 7 '13 at 6:09
    
Thanks for the reply. Any suggestions on how to troubleshoot this within PHP? –  techguy817 Mar 7 '13 at 14:50
    
Not really, no PHP skillz - you could try to work around it by adjusting fastcgi parameters (assuming you're using fastcgi) to a lower request threshold. I'd guess that if you watched the memory use of the php.exe processes, they'd be climbing until they hit this problem. If so, reducing the number of requests per process before the process is recycled might get you further. –  TristanK Mar 9 '13 at 1:09
    
Yes I am using FastCGI. I can monitor the memory usage of PHP.exe but how would I reduce the number of requests per process? –  techguy817 Mar 9 '13 at 15:26
    
iis.net/configreference/system.webserver/fastcgi (see Configuration Sample) as a starting point. You could try slightly increasing the number of fastcgi worker processes, and reducing instancemaxrequests significantly. And/or customizing settings so that the upload bits are in a separate application (or Fcgi application pool) –  TristanK Mar 13 '13 at 0:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.