Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to setup my BIND with a domain I own and I'm using dnssy.com and intodns.com to check if everything is ok, but I'm getting errors in both. The error says that my DNS server is "lame" (which I don't understand what does it mean).

My named.conf

options {
    directory "/var/dns";
    pid-file "/var/run/named/named.pid";
    auth-nxdomain yes;
    datasize default;
    listen-on-v6 { any; };
    listen-on { 127.0.0.1; 188.165.234.51; };
    listen-on-v6 { ::1; };
    allow-recursion { 127.0.0.1; };
    allow-transfer { none; };
    allow-update { none; };
    allow-query { any; };
    allow-query-cache { any; };
    version none;
    hostname none;
    server-id none;
};
include "/var/dns/autogen-zones";

autogen-zones is an autogenerated file which contains the following:

zone "localhost" IN {
     type master;
     file "localhost.zone";
     allow-transfer { any; };
};
zone "0.0.127.in-addr.arpa" IN {
     type master;
     file "127.0.0.zone";
     allow-transfer { any; };
};
zone "." IN {
     type hint;
     file "root.hint";
};
zone "destinosxures.com" IN {
     type master;
     file "destinosxures.com.zone";
     allow-query { any; };
     allow-transfer { any; };
};

Last, my destinosxures zone:

$TTL 604800
@ IN SOA ns367310.ovh.net. hostmaster.destinoxures.com. (
  2012030503   ; Serial yyyy/mm/dd/id
       10800   ; Refresh
        3600   ; Retry
     604800   ; Expire
      10800 ) ; Negative Cache TTL

@ IN NS    ns367310.ovh.net.
@ IN NS    sdns2.ovh.net.

ns1     IN A 188.165.234.51
ns2     IN A 188.165.234.51
@       IN A 188.165.234.51
www     IN A 188.165.234.51

http.tcp SRV 0 3 80 destinoxures.com.
https.tcp SRV 1 0 443 destinoxures.com.

Oh, by the way, my resolv.conf has:

nameserver 127.0.0.1
nameserver 213.251.188.141

What is wrong with my config?

Regards

share|improve this question
1  
It may be cut-and-paste error, but your named.conf lists the zone as destinosxures.com while the zonefile itself refers only to destinoxures.com (note missing central "s"). If that reflects what's really on your server, then it's definitely a problem. –  MadHatter Mar 6 '13 at 8:40
    
@MadHatter Oh my god... That is probably the sillies typo I have ever made. Please copy/paste your comment as an answer so I can accept it and choose it as an answer :) –  alexandernst Mar 6 '13 at 8:44
add comment

1 Answer

up vote 3 down vote accepted

Your named.conf lists the zone as destinosxures.com while the zonefile itself refers only to destinoxures.com (note missing central "s"). If that reflects what's really on your server, then it's definitely a problem.

And may I in passing thank you for not obscuring the domain name in the question; if you had, we'd likely never have found the answer. Others who are posting questions, particularly DNS questions, please take note.

share|improve this answer
    
I agree, not obscuring the domain name was vital for my question :) –  alexandernst Mar 6 '13 at 8:53
    
one more question (exactly same config). I'm getting this error: "Glue is not provided by your nameservers. You should add A records for your nameservers into your domain zone to fix this.". How can I fix it? –  alexandernst Mar 6 '13 at 11:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.