Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am attempting to install IIS7 "Application DevelopmentASP" role via the Server Manager's "Add Role Services" wizard. Some of the roles include ASP.Net, .Net Extensibility, ASP, ISAPI Extensions, etc. I have now successfully installed other roles under the Application Development heading. ASP is the only issue When attempting to install these I receive the following error for each service that I attempt to install:

Attempt to install <the service name> failed with error code 0x80070643.  Fatal error during installation.

I am able to successfully add Role Services that do not belong "Application Development". For example, I was able to install Health and Diagnostics -> Tracing, Custom Logging, and ODBC Logging without an issue.

I have tried the following:

-The 2 Methods here: http://support.microsoft.com/kb/976982  
    -Microsoft Fix It 50123 *EDIT Added this*
    -Repair .Net Framework 4.0
-Removed WAS (Windows Process Activation Service) from Features, Restarted server, and then attempted to install the role services.

I the following System:

Windows Server 2008 R2 Standard SP1 64 bit

Edit 3/7/13

I have now successfully been able to add roles under "Application Development", but was not able to do these all at once because I still experience the issue with the "ASP" role. The issue with this single role was stopping me from installing any of the others at the same time. I have now individually installed those, but still want to install ASP.

share|improve this question
    
Have you tried the 1st resolution method in support.microsoft.com/kb/976982 ? –  Mathias R. Jessen Mar 6 '13 at 17:37
    
Yes, I forgot to mention. I tried that before repairing the .Net Framework –  jpsnow72 Mar 6 '13 at 18:34
    
I edited my question to make note of that. –  jpsnow72 Mar 6 '13 at 18:37

2 Answers 2

I would try:

  • C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -ua
  • restart.
  • add roles/features.
  • restart.
  • aspnet_regiis.exe -i

If you need other/multiple versions of ASP.NET, you would need to run the appropriate aspnet_regiis.exe -i for that version/platform (x86/x64).

For more details see see the MSDN page for the ASP.NET IIS Registration Tool

share|improve this answer
    
Thanks for the answer. After performing the uninstall I am still getting the error when I attempt to add the roles. I noticed that it only uninstalls ASP.NET (2.0.50727). Is that right? –  jpsnow72 Mar 7 '13 at 19:17
    
I now am able to install some of the roles, but still can't install "ASP". Please see edit in my QUestion. –  jpsnow72 Mar 7 '13 at 19:30

Since I was unable to get this work any other way, everything was re-installed from scratch and it now functions properly.

Thanks for the answers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.