Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Today I applied the most recent xen update for Debian Squeeze from [Security]. The package version is now 4.0.1-5.8.

After that, xend began to behave weird (aka. wrong):

root@root:~# sudo service xend restart
Restarting Xen daemons: xend/etc/xen/scripts/network-route: line 20: /etc/xen/scripts/hotplugpath.sh: No such file or directory
/etc/xen/scripts/network-route: line 28: /proc/sys/net/ipv4/conf/eth/proxy_arp: No such file or directory
/etc/xen/scripts/network-route: line 20: /etc/xen/scripts/hotplugpath.sh: No such file or directory
/etc/xen/scripts/network-route: line 28: /proc/sys/net/ipv4/conf/eth/proxy_arp: No such file or directory
 xend/etc/xen/scripts/network-route: line 20: /etc/xen/scripts/hotplugpath.sh: No such file or directory
/etc/xen/scripts/network-route: line 28: /proc/sys/net/ipv4/conf/eth/proxy_arp: No such file or directory
/etc/xen/scripts/network-route: line 20: /etc/xen/scripts/hotplugpath.sh: No such file or directory
/etc/xen/scripts/network-route: line 28: /proc/sys/net/ipv4/conf/eth/proxy_arp: No such file or directory
/etc/xen/scripts/network-route: line 20: /etc/xen/scripts/hotplugpath.sh: No such file or directory
/etc/xen/scripts/network-route: line 28: /proc/sys/net/ipv4/conf/eth/proxy_arp: No such file or directory

It worked before without any error, hence my question: Is this a bug or is it my fault?

Btw, I'm shure I did not change something around xen, i.e. not the xend-config.sxp or any of the scripts in /etc/xen/scripts. That's why I take this old question here for unrelated, or at least only related in the manner that the package is incomplete again, as it was at that time according to only answer. (Which in turn would be a bug, right?)

share|improve this question
    
cat /proc/sys/net/ipv4/conf/eth/proxy_arp this is a kernel IPv4 setting not directly related to xen. It should exist... –  Nils Mar 6 '13 at 21:20
    
Well it does, the script just does not get it that the interface is called eth0. –  cimnine Mar 7 '13 at 7:14

1 Answer 1

According to the Xen wiki the script network-route should not be used anymore starting with Xen 4.1. Unfortunately I'm on Xen 4.0, but I figured what has to be done manual in the next version can I configure manually already.

This means, on ifup eth0 I trigger echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp:

# /etc/network/interfaces
auto eth0
iface eth0 inet static
    address 1.1.1.1
    broadcast 1.1.1.255
    netmask 255.255.255.0
    gateway 1.1.1.254

    post-up echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp

And in /etc/sysctl.conf I set net.ipv4.ip_forward = 1.

That is pretty much what the /etc/xen/scripts/network-route would have done.

share|improve this answer
    
Just out of curiosity: Why do you not use bridging? I always refrain from activating ip_forwarding. This could turn your box into a router without wanting it - the network-guys do not like that very much... –  Nils Mar 7 '13 at 20:54
    
Because my hoster does now allow it –  cimnine Mar 8 '13 at 8:31
    
He does not allow multiple MACs on one interface? This is something I would understand. –  Nils Mar 8 '13 at 13:49
    
That's right, he doesn't. –  cimnine Mar 8 '13 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.