Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I set up openssh on my server to listen to xx port and to use authorized_keys. From a Windows client, I am able to login to my server using my passphrase using putty. All Ok. This is what I wanted.

The problem now: With an Ubuntu desktop I use connect to server, I select the method = ssh, port = xx, host = ip, folder = correct folder, etc. Click connect and boom I am connected. Is this a bug?

When I use sftp using ssh to connect to a server, is it suppossed to obey the openssh config settings? Is it supposed to ask me for the passphrase instead of username/password?

If this the way it behaves then what other services are bypassing config files?

Could please give me a hint to avoid that.

share|improve this question
add comment

1 Answer

Unless you've specifically disabled password authentication, the server will accept either password or key authentication. Clients will typically attempt key authentication first and fallback to password authentication if it fails, but a client could attempt password authentication first.

You'll probably find that the Ubuntu desktop has cached your SSH key passphrase, either because your passphrase is the same as your login password, or because you've used it before during that session and the key has been cached.

share|improve this answer
    
mgorven, thanks for the input. I was guessing that. I can't reboot my system now. I read that it is a bug in ubuntu system but I am hoping that a reboot will do it. In ssh config file in my server I set it to no accept passwords at all. Only key authentication. One other extrange thing that I noticed is that ubuntu claim that is a secure system since install. However after you install it you have access to all services like http, ssh, etc. It is hard for a new guy like me to realized that after install a service I have to go a change settings to restrict access. I am learning quickly –  tito_santana Mar 7 '13 at 18:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.