Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have got a certificate from Comodo and I wanted to add it to my website which is on a shared hosting. However, I ran into two problems:

  1. I generated the CRS in my hosting panel and got a cert the file based on it. I have added the certificate in my hosting panel to the corresponding CRS. It shows the valid dates, IP, and active status, however when I go to my website there is no HTTPS.

  2. After I added the certificate and activated the SSL the domain name http://mywebsite[.]se stopped working, however http://www.mywebsite[.]se works normally. I have checked the .htaccess file and there is no redirects in that.

So basically, I cannot get the SSL work and I have lost the control on http://mywebsite[.]se.

PS: In case it helps the website address is http://www.bitech.se

share|improve this question
    
It often does help supplying the actual domain when asking a question, especially a DNS question. In this case, I think it has given me the clue to your true problem. –  Ladadadada Mar 7 '13 at 23:38

1 Answer 1

up vote 0 down vote accepted

I just checked and both http://bitech.se/ and http://www.bitech.se/ are working fine. The same page is returned for both. No redirects were returned.

https://bitech.se/ is also working fine, the SSL is valid and has no errors.

https://www.bitech.se/ does not work. The TCP connection times out.

Since www.bitech.se and bitech.se resolve to different IP addresses, I suspect you have a firewall dropping packets to port 443 on the IP address 188.95.227.20 but allowing them on 188.95.231.125.

share|improve this answer
    
is there any way to redirect all packets, whether heading for either IP or http to the bitech.se? –  Erfan Mar 8 '13 at 23:50
    
Why not change your DNS records so they both point to the same IP address? –  Ladadadada Mar 8 '13 at 23:51
    
In the DNS settings I set both @ and www to 188.95.227.20. In the .htaccess I have set the RewriteEngine on RewriteCond %{HTTP_HOST} ^www\.(.*) RewriteRule ^.*$ https://%1/$1 [R=301,L] Now when I access the site via non-www I will get the http as usual how can I redirect http to https for non-www? I did google it but nothing this particular popped up. –  Erfan Mar 9 '13 at 0:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.