Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

everyone, I connect two PCs both with 1000Mbps NIC. One(A) of them runs Fedora 8 while another(B) runs Windows7. I test bandwidth between them with Ixchariot, it shows about 10Mbps. If A and B both run Windows7, I run Ixchariot again and it shows about 1000Mbps. I transmit file from B to A(Fedora 8) and the speed is about 10Mbps. Why are the bandwidth under two tests different?

The follows are outputs from ifconfig and ethtool:

[root@Dom1 ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:24:1D:50:B9:C0  
          inet addr:192.168.1.101  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::224:1dff:fe50:b9c0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:290214 errors:0 dropped:889731948 overruns:0 frame:0
          TX packets:579263 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:19165638 (18.2 MiB)  TX bytes:875177493 (834.6 MiB)
          Interrupt:17 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4932 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4932 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5011460 (4.7 MiB)  TX bytes:5011460 (4.7 MiB)

[root@Dom1 ~]# ethtool -S eth0
NIC statistics:
     tx_packets: 816440
     rx_packets: 409104
     tx_errors: 0
     rx_errors: 0
     rx_missed: 0
     align_errors: 0
     tx_single_collisions: 0
     tx_multi_collisions: 0
     unicast: 408962
     broadcast: 38
     multicast: 142
     tx_aborted: 0
     tx_underrun: 0

[root@Dom1 ~]# ethtool eth0
Settings for eth0:
        Supported ports: [ FIBRE ]
        Supported link modes:   1000baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  Not reported
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: FIBRE
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
        Link detected: yes

[root@Dom1 ~]# ethtool -i eth0
driver: r8169
version: 2.2LK-NAPI
firmware-version: 
bus-info: 0000:03:00.0
share|improve this question
    
Could you provide outputs from ifconfig and ethtool? –  Huygens Mar 8 '13 at 7:59
    
[root@Dom1 ~]# ifconfig eth0 Link encap:Ethernet HWaddr 00:24:1D:50:B9:C0 inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::224:1dff:fe50:b9c0/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:290214 errors:0 dropped:889731948 overruns:0 frame:0 TX packets:579263 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:19165638 (18.2 MiB) TX bytes:875177493 (834.6 MiB) Interrupt:17 Base address:0xc000 –  user1651758 Mar 8 '13 at 8:10
    
lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:4932 errors:0 dropped:0 overruns:0 frame:0 TX packets:4932 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:5011460 (4.7 MiB) TX bytes:5011460 (4.7 MiB) –  user1651758 Mar 8 '13 at 8:10
    
[root@Dom1 ~]# ethtool eth0 Settings for eth0: Supported ports: [ FIBRE ] Supported link modes: 1000baseT/Full Supports auto-negotiation: Yes Advertised link modes: Not reported Advertised auto-negotiation: Yes Speed: 1000Mb/s Duplex: Full Port: FIBRE PHYAD: 0 Transceiver: internal Auto-negotiation: on Supports Wake-on: pumbg Wake-on: g Current message level: 0x00000033 (51) Link detected: yes –  user1651758 Mar 8 '13 at 8:29
    
I feel difficult to find the probrom. I have added the output of dmesg. –  user1651758 Mar 8 '13 at 8:46

1 Answer 1

You do have a problem with either your NIC or driver. ifconfig reports that RX packets:290214 errors:0 dropped:889731948 overruns:0 frame:0 so almost 900,00,000 packets have been dropped and only 300,000 received! That is huged!

Try investigating logs (/var/log/messages and the output of dmesg).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.