Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My VPS has around 3% CPU load, which is probably caused by sshd: unknown [net] and sshd: [accepted] commands appearing around once per second and quickly disappearing in htop.

Does it mean somebody is trying to bruteforce my password? What do I do about it?

share|improve this question
    
Try looking at your logs. –  Michael Hampton Mar 9 '13 at 11:08
    
Yep, they're bruteforcing based on dictionary :( –  Alexei Averchenko Mar 9 '13 at 11:11

2 Answers 2

up vote 1 down vote accepted

Check your /var/log/auth.log you should see a high number of failed attempts if someone is trying to attack you. It's commonly known as Internet Background noise.

You can install a a host based intrusion detection system like OSSEC and enable the active response to temporarily block offending IP addresses.

share|improve this answer
  1. Check your /var/log/auth.log
  2. Install fail2ban and autoban ssh bruteforcers. You can edit /etc/fail2ban/jail.conf:

    [ssh]
    
    enabled = true
    port    = 22
    filter  = sshd
    logpath  = /var/log/auth.log
    bantime = -1
    maxretry = 5
    
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.