Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a windows 2008 dev/testing server setup for testing web apps. I just installed ibm client access (v6r1m0) and after my reboot my sites now get a 503 service unavailable error.

My application pools will not start and I get the following in the application logs: The worker process for application pool 'ASP.NET v4.0' encountered an error 'Cannot read configuration file due to insufficient permissions ' trying to read global module configuration data from file '\?\C:\Windows\Microsoft.NET\Framework64\v4.0.30319\CONFIG\machine.config', line number '0'. Worker process startup aborted.

I had everything working just fine until the ibm install.

I am very grateful to anyone that can help out this developer swimming in unfamiliar waters.

share|improve this question

1 Answer 1

Looks like installing V6R1M0 .net access will adversely modify the permissions on machine.config. Re-adding network service to the permissions of C:\Windows\Microsoft.NET\Framework{.net version}\Config\machine.config did the trick.

share|improve this answer
1  
See this IBM support article. Also, the actual XML can be left corrupt in some cases. –  Ant Sep 18 '13 at 9:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.