Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

x86 Solaris 11.1 had a mirrored ZFS root pool (rpool) which was 2x 320GB disks, I detached one and replaced with a 500GB disk which resilvered ok so ran the "bootadm install-bootloader" and did the same for the remaining 320GB disk. Rebooted and it hangs at "Verifying DMI Pool....."

I've checked the correct disk is selected to boot so believe the boot files didn't install afterall. I booted from LiveCD then

# zpool import rpool
# bootadm install-bootloader -P rpool ALSO TRIED # bootadm install-bootloader -M -P rppol to install in MBR
#zpool export rpool
#init 6

but it doesn't change anything. How can I check the boot files are installed and correct, what is correct for an x86 install? any other suggestions?

share|improve this question
    
I tried bootadm install-bootloader -M -P rpool c3t1d0s0 c3t2d0s0 which worked, ie adding disk names. Although that's not mentioned in the docs at docs.oracle.com/cd/E26502_01/html/E28983/glxby.html –  dannix Mar 10 '13 at 16:45

1 Answer 1

up vote 1 down vote accepted

specify the disk names when running bootadm as folllows

bootadm install-bootloader -M -P rpool c3t1d0s0 c3t2d0s0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.