Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i would like to automount my backuftp with curlftpfs, i added

curlftpfs#<serverip> /backup/backupftp fuse allow_other,uid=0,gid=0,umask=0022 0 0

in /etc/fstab

and put the login details in /root/.netrc

mount -a

works but when i reboot the backupftp doesn't get mounted, i've got the same config on another machine where it does work.

dmesg doesn't show any errors, how can i debug this?

share|improve this question

Try

curlftpfs#<serverip> /backup/backupftp fuse allow_other,uid=0,gid=0,umask=0022,_netdev 0 0

_netdev requires network to be available before the mount, which is my suspicion why it isn't working.

share|improve this answer
    
i tried it but without success, still doesn't get mounted. – supernova Mar 10 '13 at 19:54
    
Same issue, what now? – danger89 Jun 23 '14 at 20:04
    
If you can mount -a successfully, copy the line from /etc/mtab to /etc/fstab which corresponds to the mount you want. – colechristensen Jul 3 '14 at 16:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.