Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm attempting to move files to another server to setup a slave. I have a database on one Postgres Server and am attempting to create a file-based backup using pg_backup. However, it never finishes executing the command.

Here is the output:

    /usr/pgsql-9.2/bin/pg_basebackup -U postgres -D - -P -Ft  > pg_backup.backup
    11247472/11247472 kB (100%), 1/1 tablespace
    NOTICE:  pg_stop_backup cleanup done, waiting for required WAL segments to be archived
    WARNING:  pg_stop_backup still waiting for all required WAL segments to be archived (60 seconds elapsed)
    HINT:  Check that your archive_command is executing properly.  pg_stop_backup can be         canceled safely, but the database backup will not be usable without all the WAL segments.
    WARNING:  pg_stop_backup still waiting for all required WAL segments to be archived (120 seconds elapsed)
    HINT:  Check that your archive_command is executing properly.  pg_stop_backup can be canceled safely, but the database backup will not be usable without all the WAL segments.
    WARNING:  pg_stop_backup still waiting for all required WAL segments to be archived (240 seconds elapsed)
    HINT:  Check that your archive_command is executing properly.  pg_stop_backup can be canceled safely, but the database backup will not be usable without all the WAL segments.
    WARNING:  pg_stop_backup still waiting for all required WAL segments to be archived (480 seconds elapsed)
    HINT:  Check that your archive_command is executing properly.  pg_stop_backup can be canceled safely, but the database backup will not be usable without all the WAL segments.
    WARNING:  pg_stop_backup still waiting for all required WAL segments to be archived (960 seconds elapsed)
    HINT:  Check that your archive_command is executing properly.  pg_stop_backup can be canceled safely, but the database backup will not be usable without all the WAL segments.

I've run this for hours on end, and it never finishes. The database is about 11GB.

Any idea why this might fail and where I'd be able to find errors?

share|improve this question
    
about archive command on the below : archive_command = 'cd .' is 'cd .' not 'cd.' , cd and dot between have space –  user200823 Nov 28 '13 at 2:47

1 Answer 1

It looks like your archive_command, which is configured in postgresql.conf is failing. We can't help you more — please provide more information, at least what is it's value?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.