Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a centos box (vps) with sendmail and I am using it to send a newsletter to mail clients. I am using a machine in my local network to send the e-mails via SMTP (AUTH PLAIN) but after sending some e-mail (35 .. 50) the connection starts to get closed by the server (centos/sendmail).

I've searched Google for a limit configuration on number of e-mails in sendmail but didn't find anything.

What configuration can I use to allow me to send more e-mails?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Have you checked sendmail log files for reaction to too high system load? [I have assumed "customized" newsletter - one "personalized" email per one recipient]

Possible fixes:

Custom mailing list software (as recommended by adamo)

OR

  • Increase confQUEUE_LA (default=8 per processor) and confREFUSE_LA (default=12 per processor) if your server can handle it
  • Configure confDELAY_LA (I would suggest 9) to make sendmail slow messages acceptance
  • introduce delays in email sending e.g. 1-2 seconds after every 10 messages
share|improve this answer
    
Welcome to SF Andrzej! Since this is a VM, I am assuming that in the case of a single mail per recipient, this will be queued locally by a web (php) form, so it might be a good idea to follow Vixie's advice and have QUEUE_LA and REFUSE_LA have the reverse values (deny accepting connections in order to clear the queue first). –  adamo Mar 12 '13 at 7:05
    
I personally prefer accepting ham e-mail in most situations. You can fine tune sendmail/server under your control to minimize delivery delays. I would like to achieve delivery of at least 90%/95% of non bulk e-mail below 5 minutes limit (standard for 2013). –  Andrzej A. Filip Mar 12 '13 at 8:48
add comment

First of all you have to read the configuration README. In there you will read aout settings your can put in the /etc/mail/acceess database that rate limit connections to your host. ClientConn: and ClientRate: are the ones.

You also need to check confMAX_RCPTS_PER_MESSAGE.

However, since you are sending a newsletter, you are better off managing this by installing appropriate software like say Mailman

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.