Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We just installed Windows Server 2008, along with SQL Server 2008. After everything was running fine, we setup Active Directory on this server and made it a Domain Controller. Now we can't connect to SQL Server remotely. We can connect locally, just not remotely.

Any ideas? None of my "allow remote connections" settings changed. I cannot figure this out. Any help is greatly appreciated!

share|improve this question
    
SQL-Server and DC on the same machine is a nogo to account microsofts commendations. –  Ice Mar 6 '11 at 13:33

2 Answers 2

up vote 2 down vote accepted

Check the Windows Firewall. I believe that the default Domain Controller Policy has a bunch of firewall rules set.

share|improve this answer
    
in that case its probably better to look at changing the group policy object –  Nick Kavadias Aug 1 '09 at 5:03
    
Any idea, specifically, which ports the default Domain Controller Policy requires? –  mbmccormick Aug 3 '09 at 12:25

You performed your installation in the wrong order. You should promote the server to be a DC before installing SQL.

From MDSN:

After SQL Server is installed on a computer, you cannot change the computer from a domain member to a domain controller. You must uninstall SQL Server before you change the host computer to a domain controller.

share|improve this answer
    
To further elaborate on this, best practice is to have only the Active Directory roles installed on a server intended to be a DC. In other words, do not install anything other than Active Directory on your DCs. This is not always possible. The reason for installing AD first, is that it changes permissions of files and the registry, messing up the installations of many other programs. Installing AD first ensures these other programs will create their necessary permissions correctly. –  shufler Jul 31 '09 at 21:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.